
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

IDE Connection Manual 

Eclipse Edition 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Copyright © 2014-2017 Sohwa & Sophia Technologies Inc. 
 
 
 

No. E090965-03 
 



 

2 / 38 
Universal Probe IDE Connection Manual - Eclipse Edition 

Table of Contents 
 

NOTES .............................................................................. 3 

Operating Precautions .........................................................................................................4 

Abbreviations, Terms and Conventions ............................. 5 

1. Creating an Eclipse Environment .................................. 7 

1.1. System Requirements ...................................................................................................7 
1.2. Necessary Software ......................................................................................................7 
1.3. Installing Software .......................................................................................................8 

1.3.1. Installing Java ......................................................................................................8 
1.3.2. Installing Eclipse ................................................................................................. 10 
1.3.3. Installation of GNU ARM Eclipse Plug-ins ................................................................ 11 
1.3.4. Installation of GNU Tools for ARM Embedded Processors .......................................... 16 
1.3.5. Installing MSYS ................................................................................................... 21 
1.3.6. Installation of OpenOCD ...................................................................................... 26 

2. Procedures for Debugging in Eclipse ........................... 27 

2.1. Launching Eclipse ....................................................................................................... 27 
2.2. Importing a Project .................................................................................................... 28 
2.3. Connecting Probe ....................................................................................................... 31 
2.4. Launching the Debugger ............................................................................................. 32 

3. Troubleshooting .......................................................... 35 

3.1. Program “make” not found in PATH .............................................................................. 35 

Revision History ............................................................. 37 

Manufacturer Information .............................................. 38 

 



 

3 / 38 
Universal Probe IDE Connection Manual - Eclipse Edition 

 

NOTES 
 
Thank you for purchasing the “Universal Probe” from Sohwa & Sophia Technologies. Correctly 
understand notes and other information in this document before using this product. 
 
 
1. A permission from the Japanese government is required when exporting the product and 

technologies described in this document to which the “Foreign Exchange and Foreign Trade Act” 
applies or bringing them out of Japan. 

2. The product described in this document is intended to be used in general electronics such as 
business equipment, communication equipment, measurement equipment, or home appliances. Do 
not use this product in special-purpose equipment such as automobile, railway, marine, or 
aerospace equipment, transportation equipment, combustion equipment, safety devices, medical 
equipment, infrastructure equipment, or nuclear power that requires special quality and reliability 
and of which failure or malfunction may directly threaten human lives or injure human bodies. The 
customer should be responsible for using this product in such equipment. 

3. It is strictly prohibited to reprint this document in whole or in part without our written permission. 
4. The contents of this document are subject to change without notice. 
5. The specifications in this document may lead to different results depending on your environment or 

measurement conditions. 
6. Note that we bear no responsibility for consequence of operating this product. 
7. “Operating Precautions” in this document are important notes to prevent damage on users and 

third parties as well as assets and to use the product safely and correctly. Be sure to read these 
precautions before using this product. 

8. The product names and trade names in this document are trademarks or registered trademarks of 
respective owners. 

 
 
 
 
 

 
Contact information can be obtained on the website of Sohwa & Sophia Technologies Inc. 
URL > http://www.ss-technologies.co.jp/en/index.html 

 
 
 
 

http://www.ss-technologies.co.jp/en/index.html


 

4 / 38 
Universal Probe IDE Connection Manual - Eclipse Edition 

 

Operating Precautions 
 

 

Failure to observe the following precautions may lead to human death or 
severe injury. 

  

 
Do 

Avoid supplying voltage out of the range specified in the specifications of this product. 
Supplying the voltage out of the range may cause damage or fire. 

 
Do 

When using the target equipped with the ground terminal, ensure that the ground 
terminals of the target and peripheral equipment are connected. Failure to do so may 
cause an equipment failure or electric shock. 
Avoid connecting the ground terminal to the gas pipe. This causes a fire or explosion. 

 
Don't 

Do not transport this product with equipment connected. 
In particular, hold the plug when removing or inserting the cable. Failure to do so may 
damage the cable, causing a fire or electric shock. 

 
Don't 

Observe the following points when handling the cable. Do not damage, process, 
forcibly bend, twist, pull, putting any object on or heat the cable, moving the cable 
close to the heating device, or touch the cable with a wet hand. 
Failure to observe these precautions may cause a fire or electric shock. 
If the cable is damaged, stop using it. 

 
Don't 

When you hear thunders, do not touch the power plug. This causes an electric shock. 
If the product seems to be damaged by lightning strike, stop using it. 

 
Don't 

Do not let a staple, clip or other metal items enter into the product. This may cause a 
fire or failure. 

 
Don't 

Do not use or leave the product in direct sunlight, near heating devices, in an extremely 
hot or cold environment, under hard vibrations, in dusty area with a large amount of 
metal dust or oily dust, or noisy area full of spike noise. 
Do not apply a strong shock to the product. 

 
Do not 

disassemble 

Do not disassemble, alter or repair the product. This may cause a fire or electric shock. 

 
No wetting 

Do not use the product at a place where there is liquid or at a humid place such as 
bathroom or in vicinity to glasses.  
This may cause an electric shock. 
If liquid enters into this product, immediately turn it off and stop using it. 

 
Caution 

Touching the energized product for a long time may cause low-temperature burns. 
Do not use this product covering with comforter or other cloth. 

 
Pull out the 

plug. 

Immediately turn the power off if unusual smell, noise, smoke or fire is detected or if 
the product is or may be damaged due to a fall or strong shock. Continuing to use it 
may lead to a serious accident. Stop using the product. 
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Abbreviations, Terms and Conventions 
This section describes the abbreviations, terms and conventions used in this document. 
 

 About numeric values ... All the numeric values are positive unless otherwise specified. 
 K (capital letter) ... Represents 210=1024. (Example: 16 K=16384) 
 k (small letter) ... Represents 1000. (Example: 1 kHz=1000 Hz) 
 [xxxxx] ... Represents the window title, xxxxx. 
 <xxxxx> … Represents the item named xxxxx in the window. 

 
 
 
The annotations and notes used in this document are as shown in Figure 1. 
 
 
 

 Information reference. 

 
 

 Supplementary information. 

 
 

 Caution. Be sure to read this. 

 
 

Figure 1 
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The abbreviations and terms are as shown in Table 1. 
 

Table 1 

Abbreviations and terms Description 

This product Universal Probe including accessories. 

Probe Universal Probe itself. 
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1. Creating an Eclipse Environment 
This chapter describes how to create an ARM CPU environment on a Windows PC based on Eclipse and 
GNU Tools for ARM Embedded Processors. 
 

 

The software versions and download URLs are as of the preparation of this document. 
We do not guarantee that software version, download URLs, compatibility, and screen 
configurations will remain unchanged at the time that the user creates an environment. 

 
 

1.1. System Requirements 
 
The following system is required to run this software. 
 

 PC running Microsoft Windows 7 or later 
 CPU: 1GHz or faster (depending on the requirements of the used OS) 
 Memory: 1GB or larger (depending on the requirements of the used OS) 
 HDD: At least 500 MB available free hard disk space. 
 OS: Windows 7 or later (32bit or 64bit versions are supported) 
 One or more empty USB 2.0 ports 

 
 

1.2. Necessary Software 
 
To create a development environment in which Eclipse is used, the following software is required. 
 

Table 2 

Software name Download URL 

Java www.java.com 

Eclipse https://www.eclipse.org/downloads/ 

GNU ARM Eclipse Plug-ins (Download is carried out within Eclipse.) 

GNU Tools for ARM https://launchpad.net/gcc-arm-embedded/+download 

MSYS http://sourceforge.net/projects/mingw/files/Installer/ 

OpenOCD http://www.freddiechopin.info/en/download/category/4-openocd 
 
 
 

http://www.java.com/
https://www.eclipse.org/downloads/
https://launchpad.net/gcc-arm-embedded/+download
http://sourceforge.net/projects/mingw/files/Installer/
http://www.freddiechopin.info/en/download/category/4-openocd
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1.3. Installing Software 
 
 

 Depending on the PC you use, you may need administrative rights to install software. 

 
 
1.3.1. Installing Java 
 
1) Download the Java installer from the following URL. 
 

www.java.com 

 
 
2) Double-click the downloaded file and then click the               button. 
 

 
Figure 2 

 
 

 If you do not agree with the provisions of the license agreement, click Cancel. 

 
 

Install> 

http://www.java.com/
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3) When the installation is completed, click the  button. 
 

 
Figure 3 

 
4) Java has now been installed. 
 
 
 

Close 
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1.3.2. Installing Eclipse 
 
1) Access the following URL. 
 

https://www.eclipse.org/downloads/ 

 
 
2) Download Eclipse IDE for C/C++ Developers.  

Select 32 bit or 64 bit, depending on the OS installed on your PC. 
 

 
Figure 4 

 
3) Unzip the downloaded zip file. 

 
4) Eclipse has now been installed. 
 
 
 
 
 
 
 
 

Select either 32 bit 
or 64 bit. 

https://www.eclipse.org/downloads/
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OK 

 
1.3.3. Installation of GNU ARM Eclipse Plug-ins 
 
1) Open the folder that has been unzipped from the Eclipse zip file and run eclipse.exe. 
 

 
Figure 5 

 
2) Specify the folder that you will use as Workspace and click the         button. 
 

 
Figure 6 

 
3) Select "Help" → "Install New Software..." from the menu. 

 

 

Figure 7 
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Add 

OK 

Next> 

 
 
4) Click the         button. 
 

 

Figure 8 
 
5) Enter the following text and click the        button. 

 
Name ： GNU ARM Eclipse Plug-ins 
<Location> ： http://gnuarmeclipse.sourceforge.net/updates 
 

 

Figure 9 
 
6) GNU ARM C/C++ Cross Development Tools will be displayed in the list. Select the checkbox and click 

the         button. 
 
 

 

Figure 10 
 
 
 
 
 
 
 

http://gnuarmeclipse.sourceforge.net/updates
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Next> 

Finish 

 
7) Items to be installed will be displayed. Check them and click the         button. 
 

 
Figure 11 

 
8) The Eclipse Foundation Software User Agreement will be displayed. If you accept its terms, select "I 

accept the terms of the license agreement" and click the         button. 
 

 

Figure 12 
 

 If you do not agree with the contents of the license agreement, cancel the installation. 

 
 
9) Installation will start. Wait until the installation finishes. 
 

 
Figure 13 
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OK 
10) If a warning dialog box saying "You are installing software that contains unsigned content." is 

displayed, click the         button. 
 

 
Figure 14 

 
11) You will be prompted to restart Eclipse. Click the         button. 
 

 

Figure 15 
 
12) You will be prompted to check Workspace again. Confirm that the folder indicated on the window is 

the same folder as selected in Step 2) and click the          button. 
 

 
Figure 16 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Yes 

OK 
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13) Select "Help" → "Installation Details" from the Eclipse menu, and confirm that the plug-in you 

checked in Step 7) has been installed. 
 

 
Figure 17 

 
Figure 18 

 
14) GNU ARM Eclipse Plug-ins have now been installed. 
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1.3.4. Installation of GNU Tools for ARM Embedded Processors 
 
1) Access the following URL. 
 

https://launchpad.net/gcc-arm-embedded/+download 

 
 
2) Download Windows Installer. 
 

 

Figure 19 
 
3) Run the downloaded file. 
 
4) The Language Selection dialog box will open. Select "English" and click the          button. 
 

 
Figure 20 

 
5) You will be asked whether you want to install the software. Click the         button. 
 

 

Figure 21 
 
 

OK 

Yes 

https://launchpad.net/gcc-arm-embedded/+download
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6) Click the         button. 
 

 

Figure 22 

Next> 
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7) You will be prompted to accept the terms of the license. If you accept them, select the "I accept the 

terms of the license agreement" checkbox and click the         button. 
 

 

Figure 23 
 

 If you do not agree with the contents of the license agreement, cancel the installation. 

 

Next> 
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8) Select the installation destination directory and click the         button. 
 

 

Figure 24 
 
9) You will be asked whether you want to copy the files. Click the         button. 
 

 

Figure 25 

Next> 

Next> 
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10) File copying will start. Wait until it finishes. 
 
11) When the file copying finishes, click the         button.  

If you do not need to have the actions indicated in the dialog box executed, unselect all the 
checkboxes. 

 

 

Figure 26 
 
 
12) GNU Tools for ARM Embedded Processors has now been installed. 
 
 

Finish 
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1.3.5. Installing MSYS 
 
1) Access the following URL. 
 

http://sourceforge.net/projects/mingw/files/Installer/ 

 
 
2) Download mingw-get-setup.exe. 
 

 
Figure 27 

 
3) Run the downloaded file. 

 
4) Check the provisions of the license. If you accept them, click the         button. 
 

 
Figure 28 

 

 If you do not agree with the contents of the license agreement, cancel the installation. 

Install 

http://sourceforge.net/projects/mingw/files/Installer/
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5) Select the installation destination and User Interface Options, and click the           button. 
 

 
Figure 29 

 
6) The download and installation will start. Wait until the installation finishes. 
 
7) When the download and installation finish, click the           button. 
 

 
Figure 30 

 
 
 
 
 
 
 

Continue 

Continue 
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8) In the left column of the MinGW Installation Manager window, select "All Packages" → "MSYS" → 

"MSYS Base System." 
 

 
 

Figure 31 
 
9) Select msys-bash and msys-make, whose Class is bin.  

When you select these checkboxes, other Packages are also selected at the same time. Do not 
change them. 

 

   
 

Figure 32 
 
10) Select "Installation" → "Apply Changes" from the menu bar. 
 

 
Figure 33 
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11) Click the           button in the displayed window. 
 

 
Figure 34 

 
12) Confirm that "All changes were applied successfully" is displayed and then click the           

button. 
 

 
Figure 35 

Apply 

Close 
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13) Close the MinGW Installation Manager window. 
 
14) MSYS has now been installed. 
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1.3.6. Installation of OpenOCD 
 
To unzip the OpenOCD download file, separate software that can unzip the 7-Zip format is required. 
Install that software in advance. 
 

http://www.7-zip.org/ 

 
 
1) Access the following URL. 
 

http://www.freddiechopin.info/en/download/category/4-openocd 

 
 
2) Download OpenOCD 0.8.0. 
 

 
 
 
3) Unzip the downloaded file in 7-Zip format. 

 
4) Copy the unzipped folder (openocd-0.8.0) to the root folder of the C drive (C:\). 

 
5) OpenOCD has now been installed. 
 
 
 
 

http://www.7-zip.org/
http://www.freddiechopin.info/en/download/category/4-openocd
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OK 

 

2. Procedures for Debugging in Eclipse 
 

 

To perform debugging using Eclipse, you need to rewrite the firmware for the probe with 
"CMSIS-DAP Firmware" by using the Firmware Selector in advance. 
For details, refer to "Universal Probe Software Users Manual - Firmware Selector". 

 

2.1. Launching Eclipse 
 
1) Run "eclipse.exe." 
 

 
Figure 36 

 
 
2) Specify the folder to be used as Workspace and click the         button. 
 

 
Figure 37 
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Next> 

Browse 

 

2.2. Importing a Project 
 
To import a project into Eclipse, the following files are necessary: ●●●.zip and ●●●.launch. 
(Here, a project called Blinky is used as an example.) 
 
1) When Eclipse is launched, select "File" → "Import" from the menu. 
 

 

Figure 38 
 
2) Open "General," select "Existing Projects into Workspace," and click the         button. 
 

 
 

Figure 39 
 
3) Select the "Select archive file" radio button and click the         button. 

 
4) Select the Zip file for the project you want to import. In this case, select "Blinky.zip." 
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Finish 

Next> 

 
5) When you have finished making your selection, the following is displayed in the dialog box. Click the 

         button. 
 

 

Figure 40 
 
6) Once the import is completed, the screen display returns to the screen that was displayed when 

Eclipse was launched. 
 
7) Select "File" → "Import" from the menu again. 
 

 

Figure 41 
 
8) Open "Run/Debug," select "Launch Configurations," and click the         button. 
 

 

Figure 42 
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Browse 

Finish 

 
9) Click the         button and select the folder in which "Blinky Debug.launch" is stored. 
 

 

Figure 43 
 
10) Clicking the folder containing "Blinky Debug.launch" displays "Blinky Debug.launch" in the right 

column of the window. Select its checkbox and click the         button. 
 

 

Figure 44 
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2.3. Connecting Probe 
 
After starting up Eclipse, connect the probe to the PC.  
Then, connect the probe to the target using the flat cable that comes with the probe. 
 
 
 
 
 
 
 
 
 

Figure 45 
 
 
For details of the use of the probe, refer to "Universal Probe Hardware Users Manual". 
 
 
 

 
 

Target 

Flat cable 
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2.4. Launching the Debugger 
 
 
1) Select Window → "Open Perspective" → "Debug" from the menu. 
 

 

Figure 46 
 
2) Click "X" on the Welcome tab to display Debug Perspective. 
 

 
Figure 47 
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3) The window shown below will be displayed. 
 

 
Figure 48 

 
4) Select "Run" → "Debug Configurations..." from the menu. 
 

 

Figure 49 
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Debug 

 
5) Enter "Blinky" in the "type filter text" text box.  

When this text is entered, "Blinky Debug" is displayed. Select it and click the         button. 
 

 
 

Figure 50 
 
6) Build will be executed once and the download and the debugger will start.  

A sample log recorded when the debugger normally started is shown below. 
 

Table 3 
 
Open On-Chip Debugger 0.8.0 (2014-04-28-08:39) 
Licensed under GNU GPL v2 
For bug reports, read 
 http://openocd.sourceforge.net/doc/doxygen/bugs.html 
Info : only one transport option; autoselect 'cmsis-dap' 
Info : CMSIS-DAP:  SWD  Supported 
Info : CMSIS-DAP:  JTAG Supported 
Info : CMSIS-DAP:  Interface Initialised (SWD) 
cortex_m reset_config sysresetreq 
Info : add flash_bank kinetis pflash.0 
Info : add flash_bank kinetis pflash.1 
Info : add flash_bank kinetis pflash.2 
Info : add flash_bank kinetis pflash.3 
adapter speed:  1000 kHz 
Info : SWCLK/TCK = 0 SWDIO/TMS = 0 TDI = 0 TDO = 0 nTRST = 1 nRESET = 1 
Info : DAP_SWJ Sequence (reset:  50+ '1' followed by 0) 
Info : CMSIS-DAP:  Interface ready 
Info : clock speed 1000 kHz 
Info : IDCODE 0x2ba01477 
START... 
END... 
Info : k60.cpu:  hardware has 6 breakpoints, 4 watchpoints 
Info : accepting 'gdb' connection from 3333 
undefined debug reason 7 - target needs reset 
START... 
END... 
target state:  halted 
target halted due to debug-request, current mode:  Thread  
xPSR:  0x01000000 pc:  0x000004b0 msp:  0x1fff0468 
-event reset-init occured 
semihosting is enabled 
START... 
END... 
target state:  halted 
target halted due to debug-request, current mode:  Thread  
xPSR:  0x01000000 pc:  0x000004b0 msp:  0x1fff0468, semihosting 
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3. Troubleshooting 
 

3.1. Program “make” not found in PATH 
 
1) Check the path to MinGW in the PC environment variable and correct it.  

When a project is imported, the PC path where the project was created is also imported unchanged. 
Change this path. 

 

 

Figure 51 
 
2) To change the path, select "Windows" → "Perspective" → "C/C++" from the Eclipse menu and 

display the tree of the project. Right-click the uppermost level of the project tree and select 
"Properties." 
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Figure 52 
 
3) Select "C/C++ build" → "Environment" in the left column of the Property for xxxxx window.  

Change the contents of PATH according to the PC you are using. 
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Revision History 
 

Ver. No. Revision date Contents of revision 

01 09/14/2014 Initial Release. 

02 11/17/2014 Correction of typographical errors. 

03 03/31/2017 Update company information. 
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Manufacturer Information 
 

 
 

Sohwa & Sophia Technologies Inc. 
 
 

 

[Headquarters] 

  
6-2, Minami-kurokawa, Asao-ku, Kawasaki City, Kanagawa Pref., 
215-8588, JAPAN 
Web :  http://www.ss-technologies.co.jp/en/index.html 

 
 
 
 
 

http://www.ss-technologies.co.jp/en/index.html
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