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注意事項 
 
このたびは株式会社 Sohwa & Sophia Technologies製「Universal Probe」をお買い上げいただき、誠にありがとう
ございます。本書に記載されている注意事項などを正しくご理解のうえ、お使いいただきますようお願い申し上げます。 
 
 
1. 本書に記載の製品及び技術で、『外国為替及び外国貿易法』に該当するものを輸出する時、又は、国外に持ち出す時は、

日本政府の許可が必要です。 
2. 本書に記載されている製品は、一般電子機器(事務機器、通信機器、計測機器、家電製品など)に使用されることを意図

しております。特別な品質、信頼性が要求され、その故障や誤動作が直接人命を脅かしたり、人体に危害を及ぼしたりする
恐れのある特定用途機器(自動車・鉄道・船舶・航空・宇宙用機器、交通機器、燃焼機器、安全装置、医療機器、イン
フラ機器、原子力など)には使用しないでください。もしこれらの機器でご使用になる場合は、お客様の責任のもとでご使用く
ださい。 

3. 本書の内容の一部または全部を当社の文書による承諾なしに、無断で転載することは固くお断りいたします。 
4. 本書に記載の内容は、将来予告なしに変更される場合があります。 
5. 本書に記載の仕様は、お客様の環境、測定条件によって異なる結果が得られる場合があります。 
6. 運用した結果の影響について、一切の責任を負いかねますのでご了承ください。 
7. 本書に記載の「使用上のご注意」は、使用者や他者への危害と財産の損害を未然に防ぎ、安全に正しくお使いいただくため

の重要な注意事項です。ご使用になる前に必ずお読みください。 
8. 本書に記載されている製品名および商品名は、各社の商標または登録商標です。 
 
 
 
 
 

 
連絡先は 株式会社 Sohwa & Sophia Technologies のホームページでご確認ください。 
URL > http://www.ss-technologies.co.jp 

 
 
 
 
 
 

http://www.ss-technologies.co.jp/
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使用上の注意 
 

 

下記の注意を守らないと人が死亡する、または重傷を負う可能性があります。 

  

 
強制 

本製品に仕様で規定した範囲外の電源電圧を加えないでください。 
範囲外ので電源電圧を加えると、破損・火災の恐れがあります。 

 
強制 

アース端子が付いているターゲットに使用する場合は、ターゲットや周辺機器のアースを確実に接続してくださ
い。機器の故障や感電の恐れがあります。 
また、ガス管にアース端子をつながないでください。火災や爆発の原因になります。 

 
禁止 

本製品に接続した機器を取り付けたまま持ち運ばないでください。 
特にケーブルはプラグを持って抜き差ししてください。ケーブルが破損し、火災・感電の恐れがあります。 

 
禁止 

ケーブルを取り扱う場合は次の点を守ってください。「傷つけない」「加工しない」「無理に曲げない」「ねじらな
い」「引っ張らない」「物を載せない」「加熱しない」「熱器具に近づけない」「濡れた手で触らない」。 
これらを守らないと火災・感電の恐れがあります。 
もしケーブルが破損した場合、そのケーブルの使用を中止してください。 

 
禁止 

雷が鳴りだしたら、電源プラグに触れないでください。感電の原因となります。 
落雷により製品が破損したと思われる場合は、本製品の使用を中止してください。 

 
禁止 

ステープラの針、クリップなどの金属を内部に入れないでください。火災・故障の恐れがあります。 

 
禁止 

直射日光の当たる場所、熱器具の近く、極端な高温環境、極端な低温環境、振動の激しいところ、金属
や油を含むほこりの多い場所、スパイク系のノイズが発生する場所で使用したり、放置しないでください。 
また、強い衝撃を与えないでください。 

 
分解禁止 

分解・改造・修理しないでください。火災・感電の恐れがあります。 

 
水濡れ禁止 

風呂場やコップの近くなど、液体のある場所、湿気の多い場所では使用しないでください。  
感電する恐れがあります。 
液体が本製品内部に入った場合はすぐに電源を切り、使用を中止してください。 

 
注意 

通電中の本製品に長時間触れていると低温やけどになる恐れがあります。 
また、本製品を布団などで覆った状態で使用しないでください。 

 
プラグを抜く 

もし、異常なにおい・異常な音・発煙・発火した場合、または落としたり、強い衝撃を与えたりして破損、破
損した恐れのある場合は、すぐに電源を切ってください。そのまま使うと重大な事故を起こす可能性があります
ので、使用を中止してください。 



 

5 / 37 
Universal Probe IDE接続マニュアル - Eclipse編 

 

略語・用語・記載ルール 
本書で使用する略語・用語や記載ルールについて説明します。 
 

 数値について … 特に記載がない限り、数値はすべてプラスの値とします。 
 K(大文字) … 210=1024 を表します。(例：16K=16384) 
 k(小文字) … 1000 を表します。(例：1kHz=1000Hz) 
 [xxxxx] … xxxxx というウィンドウタイトルを示します。 
 <xxxxx> … xxxxx というウィンドウ内の項目名を示します。 

 
 
 
本書で使用する注釈・注意点などについては Figure 1 の通りです。 
 
 
 

 情報の参照先を表します。 

 
 

 補足情報を記載します。 

 
 

 注意事項を記載します。かならずお読みください。 

 
 

Figure 1 
 
 
略語・用語の解説は Table 1 の通りです。 
 

Table 1 

略語・用語 説明 

本製品 Universal Probe本体・付属品を含むもの。 

プローブ Universal Probe本体のこと。 
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1. Eclipse の環境構築 
 

 

各ソフトウェアのバージョンやダウンロード URL は本書作成時点のものです。 
お客様が環境構築する時のバージョン、ダウンロード URL、互換性、画面の構成などは、当社が保証するものではあり
ません。 

 
 

1.1. システム要件 
 
本ソフトウェアを動作させるためには、以下のシステムが必要です。 
 

 Microsoft Windows 7以降が動作する PC 
 CPU：1GHz以上 (使用する OS の要件に準拠します) 
 Memory：1GB以上 (使用する OS の要件に準拠します) 
 HDD：空き容量 500MB以上 
 OS : Windows 7 以降 (32/64bit) 
 USB 2.0 の空きポート 1 つ以上 

 
 

1.2. 必要なソフトウェア 
 
Eclipse を利用した開発環境を構築するためには以下のソフトウェアが必要です。 
 

Table 2 

ソフトウェア名 ダウンロード URL 

Java www.java.com 

Eclipse https://www.eclipse.org/downloads/ 

GNU ARM Eclipse Plug-ins (Eclipse内でダウンロードします) 

GNU Tools for ARM https://launchpad.net/gcc-arm-embedded/+download 

MSYS http://sourceforge.net/projects/mingw/files/Installer/ 

OpenOCD http://www.freddiechopin.info/en/download/category/4-openocd 
 
 
 

http://www.java.com/
https://www.eclipse.org/downloads/
https://launchpad.net/gcc-arm-embedded/+download
http://sourceforge.net/projects/mingw/files/Installer/
http://www.freddiechopin.info/en/download/category/4-openocd
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1.3. 各ソフトウェアのインストール方法 
 
 

 お客様の PC によってはインストール時に管理者権限が必要になる場合があります。 

 
 
1.3.1. Java のインストール 
 
1) 以下の URL から Java のインストーラをダウンロードします。 
 

www.java.com 

 
 
2) ダウンロードしたファイルをダブルクリックし、 ボタンをクリックします。 
 

 
Figure 2 

 
 

 内容に同意できない場合はキャンセルしてください。 

 
 

インストール> 

http://www.java.com/
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3) インストールが完了したら、 ボタンをクリックします。 
 

 
Figure 3 

 
4) Java のインストールはこれで終了です。 
 
 
 

閉じる 
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1.3.2. Eclipse のインストール 
 
1) 以下の URL にアクセスします。 
 

https://www.eclipse.org/downloads/ 

 
 
2) 「Eclipse IDE for C/C++ Developers」をダウンロードします。 

お客様の PC にインストールされている OS に合わせて 32bit/64bit を選択して下さい。 
 

 
Figure 4 

 
3) ダウンロードした zip ファイルを展開します。 

 
4) これで Eclipse のインストールは終了です。 
 
 
 
 
 
 
 
 

どちらか選択 

https://www.eclipse.org/downloads/
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OK 

 
1.3.3. GNU ARM Eclipse Plug-ins のインストール 
 
1) Eclipse の zip ファイルを展開したフォルダを開き、「eclipse.exe」を実行します。 
 

 
Figure 5 

 
2) Workspace として使うフォルダを指定し、         ボタンをクリックします。 
 

 
Figure 6 

 
3) メニューから、Help → Install New Software... を選択します。 

 

 

Figure 7 
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Add 

OK 

Next> 

 
 
4)         ボタンをクリックします。 
 

 

Figure 8 
 
5) 以下のように入力し、         ボタンをクリックします。 

 
<Name> ： GNU ARM Eclipse Plug-ins 
<Location> ： http://gnuarmeclipse.sourceforge.net/updates 
 

 

Figure 9 
 
6) 「GNU ARM C/C++ Cross Development Tools」がリストに表示されるので、チェックを付けて         ボタンをクリッ

クします。 
 
 

 

Figure 10 
 
 
 
 
 
 
 

http://gnuarmeclipse.sourceforge.net/updates
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Next> 

Finish 

 
7) インストールされるアイテムが表示されるので、確認した上で         ボタンをクリックします。 
 

 
Figure 11 

 
8) Eclipse Foundation Software User Agreement が表示されるので、内容に同意したら「I accept the terms of 

the license agreement」を選択し、        ボタンをクリックします。 
 

 
Figure 12 

 

 内容に同意できない場合はキャンセルしてください。 

 
 
9) インストールが始まるので、終わるまで待ちます。 
 

 
Figure 13 
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OK 
 
10) “未署名のソフトウェアをインストールしている“と警告ダイアログが表示された場合は         ボタンをクリックします。 
 

 
Figure 14 

 
11) Eclipse の再起動を要求されるので、         ボタンをクリックします。 
 

 

Figure 15 
 
12) 再度Workspaceの確認が求められるので、手順2)で選択したフォルダと同じであることを確認して         ボタンをクリッ

クします。 
 

 
Figure 16 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Yes 

OK 
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13) Eclipse のメニューから、Help → Installation Details を選択し、手順 7)で確認したプラグインがインストールされている

ことを確認します。 
 

 
Figure 17 

 
Figure 18 

 
14) これで GNU ARM Eclipse Plug-ins のインストールは終了です。 
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1.3.4. GNU Tools for ARM Embedded Processors のインストール 
 
1) 以下の URL にアクセスします。 
 

https://launchpad.net/gcc-arm-embedded/+download 

 
 
2) Windows Installer をダウンロードします。 
 

 

Figure 19 
 
3) ダウンロードしたファイルを実行します。 
 
4) [Language Selection]ダイアログが開くので、「English」を選択して         ボタンをクリックします。 
 

 
Figure 20 

 
5) インストールするか問われるので、         ボタンをクリックします。 
 

 

Figure 21 
 
 

OK 

Yes 

https://launchpad.net/gcc-arm-embedded/+download
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6)          ボタンをクリックします。 
 

 

Figure 22 

Next> 
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7) ライセンスの同意を求められるので、同意できる場合は「I accept the terms of the license agreement」をチェック 

して、         ボタンをクリックします。 
 

 

Figure 23 
 

 内容に同意できない場合はキャンセルしてください。 

 

Next> 
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8) インストール先のディレクトリを選択して         ボタンをクリックします。 
 

 

Figure 24 
 
9) コピーするか確認されるので         ボタンをクリックします。 
 

 

Figure 25 

Next> 

Next> 
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10) コピーが始まるので、終わるまで待ちます。 
 
11) コピーが終了したら、         ボタンをクリックします。 

必要ないと判断できるなら、チェックボックスは全て OFF にしても構いません。 
 

 

Figure 26 
 
 
12) これで GNU Tools for ARM Embedded Processors のインストールは終了です。 
 
 

Finish 
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1.3.5. MSYSのインストール 
 
1) 以下の URL にアクセスします。 
 

http://sourceforge.net/projects/mingw/files/Installer/ 

 
 
2) mingw-get-setup.exe をダウンロードします。 
 

 
Figure 27 

 
3) ダウンロードしたファイルを実行します。 

 
4) ライセンスを確認し、問題なければ          ボタンをクリックします。 
 

 
Figure 28 

 

 内容に同意できない場合はキャンセルしてください。 

Install 

http://sourceforge.net/projects/mingw/files/Installer/


 

21 / 37 
Universal Probe IDE接続マニュアル - Eclipse編 

 
5) インストール先や User Interface Options を選択して          ボタンをクリックします。 
 

 
Figure 29 

 
6) ダウンロードとインストールが始まるので終わるまで待ちます。 
 
7) ダウンロードとインストールが終わったら、           ボタンをクリックします。 
 

 
Figure 30 

 
 
 
 
 
 
 

Continue 

Continue 
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8) [MinGW Installation Manager]ウィンドウの左側で、「All Packages」→「MSYS」→「MSYS Base System」を選択

します。 
 

 
 

Figure 31 
 
9) msys-bash とmsys-make の Class が bin のものを選択します。 

これらのチェックと同時に他の Package もチェックされますが、そのままにします。 
 

   
 

Figure 32 
 
10) メニューバーから、「Installation」→「Apply Changes」を選択します。 
 

 
Figure 33 
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11) 表示されたウィンドウの           ボタンをクリックします。 
 

 
Figure 34 

 
12) 「All changes were applied successfully」と表示されていることを確認し、           ボタンをクリックします。 
 

 
Figure 35 

Apply 

Close 



 

24 / 37 
Universal Probe IDE接続マニュアル - Eclipse編 

 
13) [MinGW Installation Manager]ウィンドウを閉じます。 
 
14) これで MSYS のインストールは終了です。 
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1.3.6. OpenOCD のインストール 
 
OpenOCD のダウンロードファイルは 7-Zip形式を展開できるソフトウェアが別途必要です。 
予めインストールしておいてください。 
 

http://sevenzip.sourceforge.jp/ 

 
 
1) 以下の URL にアクセスします。 
 

http://www.freddiechopin.info/en/download/category/4-openocd 

 
 
2) OpenOCD 0.8.0 をダウンロードします。 
 

 
 
 
3) 7-Zip でファイルを展開します。 

 
4) 展開して生成されたフォルダ(openocd-0.8.0)を C ドライブのルートフォルダ(C:\)にコピーします。 

 
5) OpenOCD のインストールはこれで終了です。 
 
 
 
 

http://sevenzip.sourceforge.jp/
http://www.freddiechopin.info/en/download/category/4-openocd
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OK 

 

2. Eclipse でのデバッグ手順 
 

 

Eclipse でデバッグを行うためにはプローブのファームウェアを Firmware Selector で「CMSIS-DAP ファームウェア」
に書き換えておく必要があります。 
詳しくは「Universal Probe ソフトウェア・ユーザーズ・マニュアル - Firmware Selector」を参照してください。 

 

2.1. Eclipse を起動する 
 
1) 「eclipse.exe」を実行します。 
 

 
Figure 36 

 
 
2) Workspace として使うフォルダを指定し、         ボタンをクリックします。 
 

 
Figure 37 
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Next> 

Browse 

 

2.2. プロジェクトをインポートする 
 
Eclipse でプロジェクトをインポートするには、●●●.zip と、●●●.launch ファイルが必要です。 
(ここでは Blinky というプロジェクトで説明します) 
 
1) Eclipse が起動したら、メニューから File → Import を選択します。 
 

 

Figure 38 
 
2) General を開き、「Existing Projects into Workspace」を選択し、         ボタンをクリックします。 
 

 
 

Figure 39 
 
3) 「Select archive file」のラジオボタンをクリックし、         ボタンをクリックします。 

 
4) インポートしたいプロジェクトファイルの Zip ファイルを選択します。ここでは「Blinky.zip」を選択します。 
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Finish 

Next> 

 
5) 選択が完了すると、以下のように表示されますので、         ボタンをクリックします。 
 

 

Figure 40 
 
6) 取り込みが完了すると起動時の画面に戻ります。 
 
7) 再度、メニューから File → Import を選択します。 
 

 

Figure 41 
 
8) Run/Debug を開き、「Launch Configurations」を選択し、         ボタンをクリックします。 
 

 

Figure 42 
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Browse 

Finish 

 
9)          ボタンをクリックし、「Blinky Debug.launch」を保存しているフォルダを選択します。 
 

 

Figure 43 
 
10) 「Blinky Debug.launch」を保存しているフォルダをクリックすると、ウィンドウの右側に「Blinky Debug.launch」が表示さ

れますので、チェックして         ボタンをクリックします。 
 

 

Figure 44 
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2.3. プローブの接続方法 
 
Eclipse を起動した後、プローブを PC に接続します。 
プローブ付属のフラットケーブルでターゲットに接続してください。 
 
 
 
 
 
 
 
 
 
 

Figure 45 
 
 
その他詳しい扱い方は、「Universal Probe ハードウェア・ユーザーズ・マニュアル」を参照してください。 
 
 
 
 
 
 
 
 
 
 

 
 
ターゲット 

フラットケーブル  
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2.4. デバッガを起動する 
 
 
1) メニューからWindow → Open Perspective → Debug を選択します。 
 

 

Figure 46 
 
2) Welcome タブのＸを押して、Debug Perspective を表示します。 
 

 
Figure 47 

 
 
 
 
 
 
 



 

32 / 37 
Universal Probe IDE接続マニュアル - Eclipse編 

 
3) 以下のような画面になります。 
 

 
Figure 48 

 
4) メニューから Run → Debug Configurations... を選択します。 
 

 

Figure 49 
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Debug 

 
5) type filter text と書かれたテキストボックスに「Blinky」と入力します。 

入力すると、「Blinky Debug」というものが表示されるので、選択し、         ボタンをクリックします。 
 

 
 

Figure 50 
 
6) 一度 Build が実行され、ダウンロードとデバッガが起動します。 

以下に正常起動した際のサンプルログを記載します。 
 

Table 3 
 
Open On-Chip Debugger 0.8.0 (2014-04-28-08:39) 
Licensed under GNU GPL v2 
For bug reports, read 
 http://openocd.sourceforge.net/doc/doxygen/bugs.html 
Info : only one transport option; autoselect 'cmsis-dap' 
Info : CMSIS-DAP: SWD  Supported 
Info : CMSIS-DAP: JTAG Supported 
Info : CMSIS-DAP: Interface Initialised (SWD) 
cortex_m reset_config sysresetreq 
Info : add flash_bank kinetis pflash.0 
Info : add flash_bank kinetis pflash.1 
Info : add flash_bank kinetis pflash.2 
Info : add flash_bank kinetis pflash.3 
adapter speed: 1000 kHz 
Info : SWCLK/TCK = 0 SWDIO/TMS = 0 TDI = 0 TDO = 0 nTRST = 1 nRESET = 1 
Info : DAP_SWJ Sequence (reset: 50+ '1' followed by 0) 
Info : CMSIS-DAP: Interface ready 
Info : clock speed 1000 kHz 
Info : IDCODE 0x2ba01477 
START... 
END... 
Info : k60.cpu: hardware has 6 breakpoints, 4 watchpoints 
Info : accepting 'gdb' connection from 3333 
undefined debug reason 7 - target needs reset 
START... 
END... 
target state: halted 
target halted due to debug-request, current mode: Thread  
xPSR: 0x01000000 pc: 0x000004b0 msp: 0x1fff0468 
-event reset-init occured 
semihosting is enabled 
START... 
END... 
target state: halted 
target halted due to debug-request, current mode: Thread  
xPSR: 0x01000000 pc: 0x000004b0 msp: 0x1fff0468, semihosting 
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3. トラブルシューティング 
 

3.1. Program “make” not found in PATH 
 
1) PC の環境変数に記載されている、MinGW のパスを確認し、正しいものに修正して下さい。 

プロジェクトをインポートすると、プロジェクトを作成した PC のパスもそのままインポートされますので、これを変更します。 
 

 

Figure 51 
 
2) パスを変更するためには、Eclipse のメニューから、Windows → Perspective → C/C++ を選択し、プロジェクトのツリー

を表示します。プロジェクトツリーの最上位を右クリックし、Properties を選択します。 
 

 
Figure 52 
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3) [Property for xxxxx]ウィンドウ左側の、C/C++ build → Environment を選択します。 

PATH の内容をご使用の PC に合わせて編集して下さい。 
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改訂履歴 
 

版数 改訂日 改訂内容 

01 2014/09/14 初版。 

02 2014/11/17 誤記修正。 

03 2017/03/31 会社情報を更新。 
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