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NOTES 
 
Thank you for purchasing the “Universal Probe” from Sohwa & Sophia Technologies. Correctly 
understand notes and other information in this document before using this product. 
 
 
1. Permission from the Japanese government is required when exporting the product and technologies 

described in this document to which the “Foreign Exchange and Foreign Trade Act” applies or 
bringing them out of Japan. 

2. The product described in this manual is intended to be used for general electronic equipment, such 
as office equipment, communication equipment, measuring instruments and home electric 
appliances. Do not use this product for automobile, railway, marine, aeronautical or space 
equipment, traffic equipment, combustion equipment, safety devices, medical devices, 
infrastructure equipment, nuclear power equipment or other types of equipment designed for a 
specific application that requires special quality and reliability and can directly threaten human life 
or cause damage to human body when it gets out of order or malfunctions. The customer should be 
responsible for using this product in such equipment. 

3. It is strictly prohibited to reprint this document in whole or in part without our written permission. 
4. The contents of this document are subject to change without notice. 
5. The specifications in this document may lead to different results depending on your environment or 

measurement conditions. 
6. Note that we bear no responsibility for consequence of operating this product. 
7. “Operating Precautions” in this document are important notes to prevent damage on users and 

third parties as well as assets and to use the product safely and correctly. Be sure to read these 
precautions before using this product. 

8. The product names and trade names in this document are trademarks or registered trademarks of 
respective owners. 

 
 
 
 
 

 
Contact information can be obtained on the website of Sohwa & Sophia Technologies Inc. 
URL > http://www.ss-technologies.co.jp/en/index.html 
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Operating Precautions 
 

 

Failure to observe the following precautions may lead to human death or 
severe injury. 

  

 
Do 

Avoid supplying voltage out of the range specified in the specifications of this product. 
Supplying the voltage out of the range may cause damage or fire. 

 
Do 

When using the target equipped with the ground terminal, ensure that the ground 
terminals of the target and peripheral equipment are connected. Failure to do so may 
cause an equipment failure or electric shock. 
Avoid connecting the ground terminal to the gas pipe. This causes a fire or explosion. 

 
Don't 

Do not transport this product with equipment connected. 
In particular, hold the plug when removing or inserting the cable. Failure to do so may 
damage the cable, causing a fire or electric shock. 

 
Don't 

Observe the following points when handling the cable. Do not damage, process, 
forcibly bend, twist, pull, putting any object on or heat the cable, moving the cable 
close to the heating device, or touch the cable with a wet hand. 
Failure to observe these precautions may cause a fire or electric shock. 
If the cable is damaged, stop using it. 

 
Don't 

When you hear thunders, do not touch the power plug. This causes an electric shock. 
If the product seems to be damaged by lightning strike, stop using it. 

 
Don't 

Do not let a staple, clip or other metal item enter into the product. This may cause a fire 
or failure. 

 
Don't 

Do not use or leave the product in direct sunlight, near heating devices, in an extremely 
hot or cold environment, under hard vibrations, in dusty area with a large amount of 
metal dust or oily dust, or noisy area full of spike noise. 
Do not apply a strong shock to the product. 

 
Do not 

disassemble 

Do not disassemble, alter or repair the product. This may cause a fire or electric shock. 

 
No wetting 

Do not use the product at a place where there is liquid or a humid place such as in the 
bathroom or in vicinity to glasses.  
This may cause an electric shock. 
If liquid enters into this product, immediately turn it off and stop using it. 

 
Caution 

Touching the energized product for a long time may cause low-temperature burns. 
Do not use this product covering with comforter or other cloth. 

 
Pull out the 

plug. 

Immediately turn the power off if unusual smell, noise, smoke or fire is detected or if 
the product is or may be damaged due to a fall or strong shock. Continuing to use it 
may lead to a serious accident. Stop using the product. 
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Abbreviations, Terms and Conventions 
This section describes the abbreviations, terms and conventions used in this document. 
 

 About numeric values ... All the numeric values are positive unless otherwise specified. 
 K (capital letter) ... Represents 210=1024. (Example: 16K=16384) 
 k (small letter) ... Represents 1000. (Example: 1kHz=1000Hz) 
 [xxxxx] ... Represents the window title, xxxxx. 
 <xxxxx> … Represents the item named xxxxx in the window. 

 
 
 
The annotations and notes used in this document are as shown in Figure 1. 
 
 
 

 Information reference. 

 
 

 Supplementary information. 

 
 

 Caution. Be sure to read this. 

 
 

Figure 1 
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The abbreviations and terms are as shown in Table 1. 
 

Table 1 

Abbreviations and 
terms 

Description 

This product Universal Probe including accessories. 

Probe Universal Probe itself. 

This software Pattern Generator. 

Serial No. Stands for the serial number. Probe ID. 

License Code License code for using this product. 

Software Code Code required to issue the License Code for each software. 

Host PC PC where this software runs. 

Target Object to be controlled or measured with the Universal Probe. 

PGSX format Format of a waveform settings file designed for this software. 

Paste buffer 
Buffer in the application used to store data cut or copied when editing 
waveforms. 

Single signal 1-bit signal. 

Bus A collection of single signals. 

PTN(s) Unit of output data. 1 PTN corresponds to output of a single signal. 

Start position Position at which output starts. 

End position Position at which output stops. 
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1. Overview of This Software 
 
This chapter provides an overview of this software. 
This software can be used to create waveform data and control output of the waveform data from the 
probe. 

 

Figure 2 
 

1.1. System Requirements 
 
The following system is required to run this software. 
 

 PC running Microsoft Windows 7 or later 
 CPU: 1GHz or faster (depending on the requirements of the used OS) 
 Memory: 1GB or larger (depending on the requirements of the used OS) 
 HDD: 500MB or larger free hard disk space 
 OS: Windows 7 or later (32bit or 64bit versions are supported) 
 One or more empty USB 2.0 ports 

 
 
 

 
 

Target 

Output 
waveforms 

Probe Host PC 

 
This software 

Edit 
waveforms 

User 
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1.2. Hardware Specifications 
 
For details about the hardware specifications, refer to the "Hardware Users Manual." 
 
 

1.3. Turning on or off the Power 
 
1.3.1. Connecting to the Target and Turning on the Power 
 
Connect the probe and the target with the following procedure: 
 

1) Confirm that the target is turned off. 
2) Connect the USB cable of the probe. 
3) Connect the target and the probe. 
4) Turn on the target. 
5) Start this software and edit or output waveform data. 

 
 
1.3.2. Turning off the Power and Disconnecting from the Target 
 
Disconnect the probe from the target with the following procedure: 
 

1) Exit this software. 
2) Turn off the target. 
3) Remove the probe from the target. 

 
 

 
For details on the hardware specifications of the probe, target restrictions, connection and 
other items, refer to the “Hardware Users Manual.” 
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2. How to Operate 
This chapter explains how to operate this software. 
 

2.1. Workflow 
 
The main processes from starting this software are shown in Figure 3. For the operations not described 
here, refer to "3. Menu Bar and Toolbar" or "4. Windows." 
 
 

2.2. Starting This Software   

↓   
(2.12. Opening a Waveform Data 

File or Settings File)   

↓   

2.3. Setting a Signal Type  2.13. Creating New Waveforms 

↓   
2.4. Setting Waveform Output 

Conditions   

↓   

2.5. Editing Waveforms   

↓   

2.6. Saving Waveforms and Settings   

↓   

2.7. Connecting the Probe   

↓   

2.8. Starting Waveform Output   

↓   

2.9. Stopping Waveform Output   

↓   

2.10. Disconnecting the Probe   

↓   

2.11. Exiting This Software   

 
Figure 3 
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2.2. Starting This Software 
 
● Starting operation 1 
 
Double-click the icon for this software on the desktop. 
 
 
● Starting operation 2 
 
Select "All Programs" → "Universal Probe" → "Pattern Generator" from the "Start" menu. 
 
 
The window as shown below will appear: 
 

 

Figure 4 
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2.3. Setting a Signal Type 
 
A signal type can be selected from between "single signal" and "bus." The signal type of a new waveform 
created is single signal. 
Select a signal type in the Waveform window. 
 

 Set a signal name: Clicking the Name column in the Waveform window allows you to edit the 
 signal name. 

 Create a bus: Double-clicking a signal name changes the signal into a bus.  
 A signal can be added to a bus by dragging and dropping it on the bus.  

 

 For details, refer to "4.2. Waveform area." 

 
 

2.4. Setting Waveform Output Conditions 
 
Waveform output conditions must be set before waveforms can be output. 
Set output conditions on the toolbar. 
 

 Set a data rate: Set a data rate in units of "bps" or "sec" (time). 
 Set an output voltage: Set a signal voltage to be output. 
 Operation mode: Set whether to repeat output (Repeat) or keep the final 

 output value. 
 Trigger to start waveform output: Set whether to output waveforms manually or use an 

 external trigger. 
 Waveform output start and end positions: 

 Set positions at which waveform output is to be started  
 (Start) and ended (End). 

 

 For details, refer to "3.9. Waveform Output Settings." 

 
 

2.5. Editing Waveforms 
 
Edit waveform data to be output. 
Select an area to be edited in the waveform area with the mouse, and set a value from the menu bar or 
the toolbar. 
 

 For details about how to select an area, refer to "4.2.2. Edition Area." 

 

 
For details about how to set data from the menu bar or the toolbar, refer to "3.5. Edit 
Waveform." 
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2.6. Saving Waveforms and Settings 
 
2.6.1. Save a Waveform 
 
To save waveform data, perform the following operations. 
These operations do not save the signal names, the output range, the data rate or other settings but only 
save the channel and waveform data. 
 
Tool button Operation on the menu bar Shortcut key 

 File → Save Waveform Ctrl + S 

--- File → Save Waveform As --- 

 

 For more details, refer to "3.1.4. Save Waveform As." 

 
 
2.6.2. Saving Settings 
 
To save waveform output settings, perform the following operations. 
These operations do not save the waveform data but only save the signal names, the output range, the 
data rate and other output settings. 
 
Tool button Operation on the menu bar Shortcut key 

--- File → Save Settings --- 

 

 For more details, refer to "3.1.7. Save Settings." 

 
 

2.7. Connecting the Probe 
 
To output waveforms, connect the probe. 
Connect the probe to the host PC and perform the following operations: 
 
Tool button Operation on the menu bar Shortcut key 

 Tools → Connect Ctrl + L 

 

 For more details, refer to "3.7.1. Connection." 
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2.8. Starting Waveform Output 
 
2.8.1. Standard Output 
 
To output a range of created waveform data specified by the Start and End positions, perform the 
following operations. 
If the "Repeat" mode is selected, the range between the Start and End positions is output repeatedly. 
 
Tool button Operation on the menu bar Shortcut key 

 Tools → Start Waveform Output F5 

 

 For more details, refer to "3.7.2. Start Waveform Output." 

 
 
2.8.2. Step-by-Step Output 
 
To output created waveform data on a PTN-by-PTN basis, perform the following operations. 
If the "Repeat" mode is selected, the range between the Start and End positions is output repeatedly. 
 
Tool button Operation on the menu bar Shortcut key 

 Tools → Start Waveform Output F12 

 

 For more details, refer to "3.7.3. Step-by-Step Output." 

 
 

2.9. Stopping Waveform Output 
 
To stop waveform output, perform the following operations. 
Stopping waveform output puts the probe terminal into Hi-Z state. 
If waveform data is being output on a step-by-step basis, these operations do not immediately stop 
waveform output. 
 
Tool button Operation on the menu bar Shortcut key 

 Tools → Stop Waveform Output Shift + F5 

 

 For more details, refer to "3.7.4. Stoppage of Waveform Output." 
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2.10. Disconnecting the Probe 
 
To disconnect the probe, perform the following operations: 
 
Tool button Operation on the menu bar Shortcut key 

 Tools → Disconnect Ctrl + L 

 
 

2.11. Exiting This Software 
 
To exit this software, perform the following operations or click the X button at the right top of the 
window. 
 
Tool button Operation on the menu bar Shortcut key 

--- File → Exit Application --- 

 

 For more details, refer to "3.1.12. Exit Application." 
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2.12. Opening a Waveform Data File or Settings File 
 
To open an existing waveform data file or waveform settings file, perform the following operations: 
 
Tool button Operation on the menu bar Shortcut key 

 File → Open Waveform Ctrl + O 

--- File → Open Settings --- 

 
 
 

2.13. Creating New Waveforms 
 
To create new waveforms, perform the following operations: 
 
Tool button Operation on the menu bar Shortcut key 

 File → Create New Waveform Ctrl + N 

 
 
 

 
Creating new waveforms clears the waveform data and waveform settings. 
Before creating new waveforms, save the current waveform data and waveform settings. 
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3. Menu Bar and Toolbar 
 
This chapter explains the different groups of the menu bar and the toolbar of this software. 
 
 
● Restrictions in the compact mode 
 
In the compact mode, the following menus are disabled: 
 

 Edit 
 Waveform Display 
 Edit Waveform 
 File → Create New Waveform 
 File → Save Waveform in Image File 
 File → Print 
 File → Preview Print 
 File → Set Printer 

 
 

 For details about the compact mode, refer to "4.1. Main Window." 
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3.1. File 
 
3.1.1. Create New Waveform 
 
Clears the current window for creating new waveforms. 
If the current waveform data has not been saved, a confirmation message dialog box appears before 
new waveforms are created. 
 
Tool button Operation on the menu bar Shortcut key 

 File → Create New Waveform Ctrl + N 

 
 

Table 2 

Message Description 

The waveform data has not 
been saved. 
Do you want to save it? 

Appears when the current waveform data has not been saved. 
          Saves waveform data under a new name ("3.1.4. Save 
Waveform As") and creates new waveforms.  
          Creates new waveforms without saving the current 
waveforms. 
          Cancels the operation of creating new waveforms. 

 
 

 
This menu item cannot be selected while waveforms are being output. Stop waveform output 
before selecting this menu item. 

 

Yes 

No 

Cancel 
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3.1.2. Open Waveform 
 
Opens a waveform data file. 
The waveform settings are retained. 
Select a desired file on the file dialog box displayed. 
Files in CSV, VCD or binary formats can be opened. 
If the current waveform data has not been saved, a confirmation message dialog box appears before a 
waveform file is opened. 
 
Tool button Operation on the menu bar Shortcut key 

 File → Open Waveform Ctrl + O 

 
Table 3 

Message Description 

The waveform data has not 
been saved. 
Do you want to save it? 

Appears when the current waveform data has not been saved. 
          Saves waveform data under a new name ("3.1.4. Save 
Waveform As") and opens another waveform data.  
          Opens waveform data without saving the current 
waveforms. 
          Cancels the operation of opening waveform data. 

 
 

 
This menu item cannot be selected while waveforms are being output. Stop waveform output 
before selecting this menu item. 

 

 
If you load a VCD file, please sure you have pre-selected the data rate faster than the 
timescale that is written in the VCD file within. 

 
 
 
3.1.3. Save Waveform 
 
Overwrites the current file with the current waveform data. 
When you are creating new waveform data, specify a file name on the file dialog box displayed. 
Waveform data is saved in CSV format. 
 
Tool button Operation on the menu bar Shortcut key 

 File → Save Waveform Ctrl + S 

 
 

 
These operations do not save the waveform settings but only save the waveform data. 
Save the waveform settings according to "3.1.7. Save Settings." 

 
 

Yes 

No 

Cancel 
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3.1.4. Save Waveform As 
 
Saves waveform data in a file. 
Specify a file name on the file dialog box displayed. 
Waveform data is saved in CSV format. 
 
The waveform settings can also be saved by checking <Save settings file too> in the file dialog box. The 
waveform settings file is saved under the name of "specified file name.pgsx" (PGSX format) (refer to 
Figure 5). 
 
Tool button Operation on the menu bar Shortcut key 

--- File → Save Waveform As --- 

 

  
Figure 5 

 
 

 

These operations do not save the waveform settings when <Save settings file too> is not 
checked. Only save the waveform data. 
Save the waveform settings according to "3.1.7. Save Settings." 
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3.1.5. Save Waveform in Image File 
 
Saves the current waveform area as a PNG image file. 
Specify a file name on the file dialog box displayed. 
Figure 6 shows an example of a saved image. 
 
Tool button Operation on the menu bar Shortcut key 

--- File → Save Waveform in Image File --- 

 
 

 
Figure 6 
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3.1.6. Open Settings 
 
Opens a waveform settings file. 
The waveform data is retained. 
Select a desired PGSX file on the file dialog box displayed. 
 
Tool button Operation on the menu bar Shortcut key 

--- File → Open Settings --- 

 
 
3.1.7. Save Settings 
 
Saves waveform settings. 
Specify a file name to be saved on the file dialog box displayed. 
The file is saved in PGSX format. 
 
Tool button Operation on the menu bar Shortcut key 

--- File → Save Settings --- 

 
 

 

These operations do not save the waveform data but only save the waveform settings. 
Save the waveform data according to "3.1.3. Save Waveform" or "3.1.4. Save Waveform 
As." 

 
 



 

24 / 74 
Universal Probe Software Users Manual – Pattern Generator 

 
3.1.8. Print 
 
Prints the waveform data and waveform settings. 
Make print settings in the Print dialog box opened and click the       z  button. 
 
Tool button Operation on the menu bar Shortcut key 

 File → Print Ctrl + P 

 

 
Figure 7 

 
 

Table 4 
Printer name Select a printer. 

Properties Shows the printer properties. 

Waveform data Select this checkbox to print the waveform data. 

Print range Displayed area: Prints the waveform data in the displayed range. 
All: Prints all the waveform data at the current enlargement/ 

reduction ratio. 
The number of pages to be printed is displayed in the right portion of 
the section. 

Setting 
conditions 

Select this checkbox to print the waveform settings. 

Number of 
copies 

Set the number of copies to be printed. 

 

 

When "All" of "Print range" is chosen, "memory shortage" may be caused depend on the state 
of the host PC.  
In that case, please print after having chosen "Displayed area" of "Print range" or having 
reduced "the current enlargement/reduction ratio", to reduce pages. 

 

OK 
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3.1.9. Preview Print 
 
Displays a print preview. (refer to Figure 8). 
 
Tool button Operation on the menu bar Shortcut key 

 File → Preview Print --- 

 
 

 

Figure 8 
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3.1.10. Set Printer 
 
Shows the settings of the printer to be used. This command has the same function as the Properties 
button in "3.1.8. Print." (refer to Figure 9). 
 
Tool button Operation on the menu bar Shortcut key 

--- File → Set Printer --- 

 

 
Figure 9 

 
 
 
3.1.11. Showing File History 
 
Shows up to 4 waveform data files opened in the past. 
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3.1.12. Exit Application 
 
Exit this software. 
Checks whether or not the waveform data and waveform settings have been saved and whether or not 
waveforms are being output, and shows a message dialog box accordingly. 
This software is exited after your confirmation. 
The same operation can be performed by clicking the X button at the right top of the main window. 
 
Tool button Operation on the menu bar Shortcut key 

--- File → Exit Application --- 

 
Table 5 

Message Description 

Do you want to save waveform 
data? 

Appears when the waveform data has not been saved. 
 Saves the waveform data under a new name ("3.1.4. 

Save Waveform As"). 
Exits the software without saving the waveform data. 
Cancels the operation of exiting the software. 

Do you want to save waveform 
output settings? 

Appears when the waveform settings have not been saved. 
 Saves the settings ("3.1.7. Save Settings").  
Exits the software without saving the settings. 

 Cancels the operation of exiting the software. 

Waveforms are being output. 
Do you want to stop? 

Appears when waveforms are being output. 
 Stops outputting waveforms. 
Cancels the operation of exiting the software. 

 

Yes 

Yes 

No 

Cancel 

Yes 

No 

No 

Cancel 
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3.2. Edit 
 
3.2.1. Copy to Clipboard 
 
Copies the current waveform data and waveform settings to the clipboard as an image. 
 
Tool button Operation on the menu bar Shortcut key 

 Edit → Copy to Clipboard --- 

 

 
Figure 10 

 
 
3.2.2. Copy Only Waveform to Clipboard 
 
Copies only the current waveform data to the clipboard as an image. 
 
Tool button Operation on the menu bar Shortcut key 

--- Edit → Copy Only Waveform to Clipboard --- 

 

 
Figure 11 
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3.3. View 
 
3.3.1. Showing/Hiding the Toolbar Items 
 
Shows/hides the toolbar items. 
A check ( ) at the head of a menu indicates that the corresponding menu items are shown on the 
toolbar. 
 
Tool button Operation on the menu bar Shortcut key 

--- View → Toolbar → File --- 

--- View → Toolbar → Edit --- 

--- View → Toolbar → Display Waveform --- 

--- View → Toolbar → Edit Waveform --- 

--- View → Toolbar → Tools --- 

--- View → Toolbar → Set Waveform Output --- 

 
 

 
At the time of "Compact" mode, the display switching function of "Edit", "Display Waveform", 
"Edit Waveform" is disabled. 
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3.3.2. Customize 
 
Sets the way in which to show the toolbar and keyboard shortcuts. 
The Customize window appears. 
 
Tool button Operation on the menu bar Shortcut key 

--- View → Toolbar → Customize --- 

 
 
(1) Keyboard tab 
 
Set keyboard shortcuts. 
 

 

Figure 12 
 
 

Table 6 

Category 
Select a command category. Commands listed in the Command 
field are changed depending on the category selected. 

Command Lists commands classified into the category selected. 

Current keys 
Shows the keys currently assigned to the command selected in the 
Command field. 

Press keys to be assigned. 

Enter keys to be assigned to the command selected in the 
Command field. 
Enter keys directly from the keyboard. 
If the same keys have already been assigned, a message dialog box 
(Table 7) appears. 

 

Resets changes made after the Customize dialog box is opened. 
Before they are reset, a message dialog box (Table 8) appears to ask 
you to confirm the operation. 

 

Resets all the key settings to the factory default. 
Before they are reset, a message dialog box (Table 9) appears to ask 
you to confirm the operation. 

 

Reset 

Reset All 
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Table 7 

Message Description 

The keys have already been 
used as shortcut keys. 
Enter other keys. 

Appears when the same keys have been assigned to another 
command. 
Assign other keys or change the assignment of the keys to that 
command. 

 
Table 8 

Message Description 

All the changes will be lost. 
Do you want to reset? 

Appears when you click the Reset button. 
 Executes Reset. 
 Does not execute Reset. 

 
Table 9 

Message Description 

Key settings will be reset to 
the factory default. 
Do you want to reset? 

Appears when you click the Reset All button. 
 Executes Reset All. 
 Does not execute Reset All. 

 
 
(2) Options tab 
 
Set the way in which to show the toolbar. 
 

 
Figure 13 

 

Yes 

No 

No 

Yes 
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Table 10 

Show command text in a tool tip 
Selecting this checkbox shows the command text when you place 
the mouse cursor on an icon on the toolbar (refer to Figure 14). 

Show both command text and 
shortcut keys 

Selecting this checkbox shows both the command text and the 
shortcut keys in a tool tip. 

Large icons Selecting this checkbox enlarges the icons on the toolbar. 
 
 

 
Figure 14 
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3.4. Waveform Display 
 
3.4.1. Zoom In 
 
Zooms in the waveforms on the Waveform window. 
 
Tool button Operation on the menu bar Shortcut key 

 Display Waveform → Zoom In Ctrl + 
PageDown 

 
 
3.4.2. Zoom Out 
 
Zooms out the waveforms on the Waveform window. 
 
Tool button Operation on the menu bar Shortcut key 

 Display Waveform → Zoom Out Ctrl + 
PageUp 

 
 
3.4.3. Enlarge Selected Area 
 
Enables/disables the enlarge selected area mode (toggle). 
In the enlarge selected area mode, a portion in the waveform area can be enlarged by selecting the 
portion (range) by the mouse. 
By pressing the ESC key with a range selected, that range can be deselected. 
 
Tool button Operation on the menu bar Shortcut key 

 Display Waveform → Enlarge Selected Area --- 

 
 
3.4.4. Show Whole 
 
Shows the entire waveforms. 
 
Tool button Operation on the menu bar Shortcut key 

 Display Waveform → Show Whole --- 
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3.4.5. Channel Color Mode 
 
Switches the waveform display color (toggle). 
When this mode is disabled, waveforms of all channels are displayed in black. 
When this mode is enabled, waveforms are displayed in colors set for the respective channels. 
 
Tool button Operation on the menu bar Shortcut key 

 Display Waveform → Channel Color Mode --- 

 
 

 Buses are displayed in black regardless of whether this mode is enabled or disabled. 

 
 
3.4.6. Cursor → Move to Left Edge 
 
Moves the selected cursor to the next left change point of the selected signal. 
If no signal is selected, the selected cursor is moved to the next left change point of a signal that comes 
first. 
 
Refer to Figure 15 and Figure 16 although the cursor is moved differently from these. 
 
Tool button Operation on the menu bar Shortcut key 

 Display Waveform → Cursor → Move to Left Edge --- 

 
 

 For a bus, the cursor is moved to the point where a value change occurs. 

 
(1) Selecting Move to Right Edge with a signal (Sig2) selected moves the cursor to the next change point 

of Sig2. 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 15 

Cur1 

Sig1 

Sig2 

Sig3 

Sig1 

Sig2 

Sig3 

Cur1 
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(2) Selecting Move to Right Edge with no signal selected moves the cursor to the next change point of 

Sig1, which comes first. 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 16 
 
 
3.4.7. Cursor → Move to Right Edge 
 
Moves the selected cursor to the next right change point of the selected signal. 
If no signal is selected, the selected cursor is moved to the next right change point of a signal that comes 
first. 
 
Figure 15 and Figure 16 are examples showing how the cursor is moved. 
 
Tool button Operation on the menu bar Shortcut key 

 Display Waveform → Cursor → Move to Right Edge --- 

 
 

 For a bus, the cursor is moved to the point where a value change occurs. 

 
 
 
3.4.8. Move to Edge 
 
Switches whether to move the cursor to an edge in the Waveform window (toggle). 
When this mode is disabled, the cursor is moved to the position to which it is moved. 
When this mode is enabled, the cursor is moved to the change point that comes first in the direction in 
which it is moved. 
If a signal is selected, the cursor is moved to the next change point of that signal. 
If no signal is selected, the cursor is moved to the change point that comes first of all signals. 
 
Tool button Operation on the menu bar Shortcut key 

 Display Waveform → Move to Edge --- 

 

 For a bus, the cursor is moved to the point where a value change occurs. 

Cur1 

Sig1 

Sig2 

Sig3 

Sig1 

Sig2 

Sig3 

Cur1 
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3.4.9. Start Waveform Output ← Cursor Position 
 
Moves the waveform output start position to the position of the cursor currently selected on the 
Waveform window. 
If the cursor is placed to the right of the waveform output end position, it is moved to the end position. 
 
Tool button Operation on the menu bar Shortcut key 

 Display Waveform → Start Waveform Output ← Cursor Position --- 

 
 

        

Figure 17 
 
 
3.4.10. End Waveform Output ← Cursor Position 
 
Moves the waveform output end position to the position of the cursor currently selected on the 
Waveform window. 
If the cursor is placed to the left of the waveform output start position, it is moved to the start position. 
 
Tool button Operation on the menu bar Shortcut key 

 Display Waveform → End Waveform Output ← Cursor Position --- 

 

        
 

Figure 18 
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3.5. Edit Waveform 
 
3.5.1. Input "0" (Low Level) 
 
Sets the values in an area selected in the waveform area to 0 (Low Level). 
If the selected area contains bus signals, the values of all the signals included in the bus are set to 0. 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Input "0" (Low Level) --- 

 
 
3.5.2. Input "1" (High Level) 
 
Sets the values in an area selected in the waveform area to 1 (High Level). 
If the selected area contains bus signals, the values of all the signals included in the bus are set to 1. 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Input "1" (High Level) --- 

 
 
3.5.3. Input "Hi-Z" (High Impedance) 
 
Sets the values in an area selected in the waveform area to Hi-Z. 
If the selected area contains bus signals, the values of all the signals included in the bus are set to Hi-Z. 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Input "Hi-Z" (High Impedance) --- 

 
 
3.5.4. Reverse Level 
 
Reverses value levels in an area selected in the waveform area (changes 0 to 1 and 1 to 0). 
If the selected area contains bus signals, the levels of all the signals included in the bus are reversed. 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Reverse Level --- 

 
 

 Hi-Z is not changed. 
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3.5.5. Input Value 
 
Sets an area selected in the waveform area at a specified value 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Input Value --- 

 

 This command only affects buses. 

 

 
Figure 19 

 
 

Table 11 

Numeric value 
Enter a value to be set in the area selected in the waveform area. 
If an incorrect value is entered, a message dialog box (Table 12) appears. 

Data Format 

Specify the format of data to be entered. 
Hex (hexadecimal number): 

Enter a hexadecimal number directly. There is no need to put a symbol 
to indicate that the value is a hexadecimal number. 
Example: 7F 

Decimal (decimal number): 
Enter a numerical value directly. 
Example: 12 

Binary (binary number): 
Enter a pattern of 0's and 1's. There is no need to put a symbol to 
indicate that the value is a binary number. 
Example: 0101 

ASCII (character code):  
Enter a character. There is no need to enclose characters in double 
quotation marks. 
Example: A 

 
Table 12 

Message Description 

The entered value is 
incorrect. 

Appears when a value entered cannot be represented by the bus bit width. 
Click OK and enter a correct value. 

 

OK 
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3.5.6. Input Count Value 
 
Sets an area selected in the waveform area at the count value. 
Sets the count increased (or decreased) with time according to the specified start value and increment 
value. 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Input Count Value --- 

 

 
Figure 20 

 
Table 13 

Start value Enter an initial count data value. Only a positive value can be entered. 
If an incorrect value is entered, a message dialog box (Table 14) appears. 

Increment value 
Enter a count data increment. 
If the count value is exceeds the minimum or maximum value is more than 
the width of the signal, it will wrap-around. 

Count interval 

Enter a count interval. 
If the waveform unit on the Waveform window is PTN(s), enter an interval in 
units of PTNs. 
If the waveform unit is Time, select a unit for the count interval from among 
ns (nanosecond), us (microsecond), ms (millisecond), and sec (second) in 
the combo box. 

Data Format 

Specify the format of data to be entered. 
Hex (hexadecimal number): 

Enter a hexadecimal number directly. There is no need to put a symbol to 
indicate that the value is a hexadecimal number. 
Example: 7F 

Decimal (decimal number): 
Enter a numerical value directly. 
Example: 12 

Binary (binary number): 
Enter a pattern of 0's and 1's. There is no need to put a symbol to indicate 
that the value is a binary number. 
Example: 0101 

ASCII (character code):  
Enter a character. There is no need to enclose characters in double 
quotation marks. 
Example: A 
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Table 14 

Message Description 

The entered value is incorrect. 
Appears when a value entered cannot be represented by the bus bit 
width or a negative value is entered. 

 Click OK and enter a correct value. 
 
 

 
The Input Count Value command can be used to generate a clock with 1 bit. 
By setting the increment value at 1, a waveform that repeats 0 and 1 can be created. 

 
 
 
3.5.7. Input Random Value 
 
Sets an area selected in the waveform area at a random value. 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Input Random Value --- 

 

 
Figure 21 

 
 

Table 15 

Random interval 
Select this radio button to create random data at random intervals. 
The maximum random interval is 50 PTN(s). 

Fixed interval 

Select this radio button to create random data at a fixed interval. 
If the waveform unit on the Waveform window is PTN(s), enter an 
interval in units of PTNs. 
If the waveform unit is Time, select a unit for the interval from 
among ns (nanosecond), us (microsecond), ms (millisecond), and 
sec (second) in the combo box. 

 

OK 



 

41 / 74 
Universal Probe Software Users Manual – Pattern Generator 

 
3.5.8. Cut 
 
Cuts the waveform in an area selected in the waveform area and copies it to the buffer. 
After a portion of a waveform is cut, the whole waveform is shifted leftward. If there is no data to be 
shifted in the right edge, the cut portion is filled with Hi-Z. 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Cut Ctrl + X 

 
 
3.5.9. Copy 
 
Copies the waveform in an area selected in the waveform area to the paste buffer. 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Copy Ctrl + C 

 
 
3.5.10. Paste 
 
Pastes a waveform in the paste buffer into the waveform area. 
Follow the procedure below to paste a waveform: 
 

1) Select Paste, and the area from which waveform data is to be pasted (the paste area) will be 
enclosed by a dotted line (light blue area in Figure 22). 

2) Move the paste area to a position into which the waveform data is to be pasted by dragging it with 
the mouse or using the direction keys in the keyboard. 

3) Click the mouse outside the paste area or press the Enter key, and the waveform will be pasted. 
 
By pressing the ESC key with a paste area selected, the operation of pasting waveform data can be 
canceled. 
 
If the waveform to be pasted has an edge(s), the Paste command operates differently depending on 
whether Align to Grid and Align to Edge are enabled as follows: 
 
 When only Align to Grid is enabled, the waveform is pasted in such a way that the leftmost edge 

is aligned to the nearest grid. (Figure 23) 
 When only Align to Edge is enabled, the waveform is pasted in such a way that the leftmost edge 

is aligned to the nearest edge. (Figure 24) 
 When both Align to Grid and Align to Edge are enabled, the waveform is pasted in such a way that 

the leftmost edge is aligned to the grid or the nearest edge of another signal, whichever is nearer. 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Paste Ctrl + V 
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Figure 22 

 

 

Figure 23 
 

 
Figure 24 

 
 
3.5.11. Align to Grid 
 
Switches whether to align a range selected and pasted in the waveform area to the grid (toggle). 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Align to Grid --- 

 
 
3.5.12. Align to Edge 
 
Switches whether to align a range selected and pasted in the waveform area to an edge (toggle). 
 
Tool button Operation on the menu bar Shortcut key 

 Edit Waveform → Align to Edge --- 

 
 

 Refer to “3.5.10. Paste” in Figure 24 for how these commands work. 
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3.5.13. Grid Interval 
 
Set the grid interval in the waveform area. 
Specify how many PTNs constitute an interval between two grid lines. 
If "1/10" is specified, grid lines are displayed at intervals of 10 PTNs. 
The interval can be selected from among 1/1, 1/5, 1/10, 1/20, 1/30, 1/50, 1/100, 1/200, 1/300, and 
1/500. 
 

Toolbar Shortcut key 

 Shift + F11 
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3.6. Setting 
 
3.6.1. Save Current Settings as Default 
 
Saves the current settings in the initial setting file. The values saved here are set when the software is 
started next time. 
The following settings are saved: 
 
 Settings of unit selection 

 
Before the settings are saved, a message dialog box appears (Table 16) 
 
Tool button Operation on the menu bar Shortcut key 

--- Setting → Save Current Settings as Default --- 

 
 

Table 16 

Message Description 

Do you want to save the current 
settings as the default? 

 Saves the current settings as the default. 
Cancels the operation of saving the current settings. 

 
 
3.6.2. Initialize Settings 
 
Initializes all of the current settings and resets the initial setting file to the settings when the software 
was installed. 
Before the settings are initialized, a message dialog box appears. (Table 17) 
 
Tool button Operation on the menu bar Shortcut key 

--- Setting → Initialize Settings --- 

 
 

Table 17 

Message Description 

Do you want to initialize the 
current settings and the default 
settings? 

 Initializes the settings. 
Cancels the operation of initializing the settings. 

 
 
 

Yes 

No 

Yes 

No 
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3.7. Tools 
 
3.7.1. Connection 
 
Connect between this software and the probe or disconnect them. (toggle). 
In a disconnected state, pressing this tool button displays the Select Unit dialog box (Figure 25), where 
you can select the unit to connect to. 
From the Select Unit dialog box, you can also register the license. 
 
Tool button Operation on the menu bar Shortcut key 

 Tool → Connect Ctrl + L 

 

 
Figure 25 

 

 For license registration, refer to "5. License Registration." 
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Table 18 

Serial No. 

Displays serial numbers of all probes that are connected to the host PC. 
For each probe that can be connected, a checkbox is displayed. Check 
the checkbox for the desired probe. With this software, you can select 
only one probe. 
If a probe cannot be connected because, for example, the license is not 
registered or the probe is being used for other function, the 
corresponding serial number and the checkbox are grayed out. 

Status 

Displays the status of the probe. 
Available : the probe can be connected. 
Used : the probe is used for other function. 
License unregistered : The license is not registered. 

 
Saves the current probe selection status as the default value. When 
this software is started up next time, this setting is restored as the 
default value. 
Before saving the setting, a message dialog (Table 19) prompts you to 
confirm the setting. 

 
Registers the license for the selected probe. 
 

 For details, refer to "5. License Registration." 
 

 Searches again for probes that are connected to the host PC. 

 
Connects to the probe with a checked checkbox. 
When an error occurs during connection process, a message dialog is 
displayed. (Table 20) 

 Cancels probe connection process. 

 
Table 19 

Message Description 

Do you want to save the 
current settings as the default? 

Saves the current settings as the default. 
Cancels the operation of saving the current settings. 

 
Table 20 

Message Description 

Could not find unit to connect 
to. 

This message is displayed when the desired probe cannot be found. 
Check if the probe is connected properly. 

Failed to connect. 
(XXX) 

This message is displayed when connection has failed. In the place of 
XXX, the cause of the failure is displayed. 
For the content of "XXX" (cause), refer to "A.1. HW Connection Errors." 

Save as default value 

Register License 

Update 

Connect 

Cancel 

Yes 

No 
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3.7.2. Start Waveform Output 
 
Start output of the waveform that is between 'Start Waveform Output Position' and 'End Waveform 
Output Position' in the waveform area. 
This function cannot be selected if the host PC is not connected to a probe. 
When waveform output fails, a dialog message is displayed. (Table 21) 
 
Tool button Operation on the menu bar Shortcut key 

 Tool → Start Waveform Output F5 

 
Table 21 

Message Description 

Failed to output waveform. 
(XXX) 

This message is displayed when waveform output has failed. In the place 
of XXX, the cause of the failure is displayed. 
For the content of "XXX" (cause), refer to "A.1. HW Connection Errors." 

 
 

 

Restriction imposed on waveform output 
Depending on the data rate, a restriction is imposed on the Hi-Z data output 
 
If the data rate is 1 Mbps or higher (1 us or below) and the waveform data in the 
output range has Hi-Z data, the Hi-Z data cannot be output. 
The message as shown in Table 22 is displayed and output is not started. 
Lower the data rate or delete Hi-Z data from the output range. 

 
 

Table 22 

Message Description 

At this Data Rate, it is not possible to 
output Hi-Z data. Delete Hi-Z data 
from the output range or set Data 
Rate to XX or below. 

Delete Hi-Z data from the output range or lower the data rate. 
Even if you do not actually delete Hi-Z data, output is possible 
as long as there is no Hi-Z data in the output range. 
In the place of XX, the following is displayed depending on the 
waveform unit. 
When waveform unit is PTN → 1Mbps, when waveform unit is 
Time → 1usec 

 
 
● Indications on tool bar 
 
When output is started by an external trigger, the indication on the Waveform output start button 
changes depending on the status of the probe. (Table 23) 
During waveform output, the button can not click. 
 

Table 23 

 
Outputting waveform. 
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3.7.3. Step-by-Step Output 
 
Output waveform from 'Start Waveform Output Position' that is edited in the waveform area in a 
step-by-step manner. 
Regardless of whether the operation mode is Keep mode, the outputting state is retained until the end of 
the waveform output range is reached. 
This function cannot be selected if the host PC is not connected to a probe. 
When waveform output fails, a dialog message is displayed. (Table 21) 
 
Tool button Operation on the menu bar Shortcut key 

 Tool → Step-by-Step Output F12 

 

 
While step-by-step output is performed, the output position is displayed as a green dashed line 
on the Waveform window. 
For details, refer to "4.2.2. Edition Area." 

 
 

 

Restriction imposed on waveform output 
Depending on the data rate, a restriction is imposed on the Hi-Z data output 
 
If the data rate is 1 Mbps or higher (1 us or below) and the waveform data in the 
output range has Hi-Z data, the Hi-Z data cannot be output. 
The message as shown in Table 22 is displayed and output is not started. 
Lower the data rate or delete Hi-Z data from the output range. 

 
 
● Indications on tool bar 
 
When step-by-step output is started by an external trigger, the indication on the Waveform output start 
button changes depending on the status of the trigger. (Table 24) 
During step-by-step output, the button is displayed in a recessed manner and disabled. 
 

Table 24 

 
Outputting waveform. 

 

 
Even when step-by-step output is performed, the indication on the Waveform output start 
button changes. 

 
 
● Step-by-step output action when external trigger is used 
 
A figure in below is sequence of the step-by-step output action with external trigger. 
 
 
 
 
 

Figure 26 

Push "Step-by-step 
Output". 

"Step-by-step 
execution position" 

is moved. 

External trigger 
occurred 

Output a 1 PTN of the 
left side of "Step-by-step 

execution position". 
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3.7.4. Stoppage of Waveform Output 
 
Stop waveform output and set the output to Hi-Z. 
When the waveform is not output, this function cannot be selected. 
 
Tool button Operation on the menu bar Shortcut key 

 Tool → Stop Waveform Output Shft + F5 

 
While step-by-step output is performed, the output is retained and the "Stop Waveform Output" in the 
menu or the tool bar changes to "Keep off." 
 
If waveforms are output with the "Keep mode" operation mode enabled, a message dialog box (Table 
25) prompts you to confirm your command and then the waveform output stops. 
 

Table 25 

Message Description 

Waveform is being output in 
Keep mode. 
Do you stop (Hi-Z)? 

Stops outputting waveforms. 
Cancels output stop process. 

 
 
3.7.5. Keep off 
 
Stop retention of the outputting state and set the output to Hi-Z. 
 
Tool button Operation on the menu bar Shortcut key 

 
Tool → Keep off --- 

 

 

When "Keep" operation mode is enabled and "Repeat" operation mode is disabled, once the 
end of the waveform output is reached, the Stop Waveform Output button automatically 
changes to Keep off button. 

 
 
3.7.6. Control using Run button on probe 
 
Switch to enable or disable control using Run button on the probe. 
If a checkmark ( ) is shown at the beginning of the menu, control using Run button is enabled. 
When enabled, by pressing the Run button on the probe, you can start waveform output while 
waveform output is being stopped or you can stop waveform output while waveform output is in 
progress. 
 
Tool button Operation on the menu bar Shortcut key 

--- Tool → Control by Run Button on Probe --- 

 

 
Even when this setting is enabled, it is possible to start/stop waveform output from the menu 
bar or the tool bar. 

Yes 

No 
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3.8. Help 
 
3.8.1. Help Display 
 
Display the Universal Probe product page on our web site. 
Please download the instruction manual from there. 
 
Tool button Operation on the menu bar Shortcut key 

--- Help → Help --- 

 
 
3.8.2. Version Information 
 
Display the version of this software and the information of the connected hardware. 
These pieces of information can be copied. 
 
Tool button Operation on the menu bar Shortcut key 

--- Help → About --- 

 

 
Figure 27 
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3.8.3. Demo Mode 
 
Discard the current waveform data and waveform output settings and display the waveform data for 
demonstration. 
 
Tool button Operation on the menu bar Shortcut key 

--- Help → Demo Mode --- 

 

 In Demo mode, you cannot save data to file or perform waveform output. 

 

 
The waveform data being edited and waveform output settings are discarded. Select this 
command after saving data. 

 
 



 

52 / 74 
Universal Probe Software Users Manual – Pattern Generator 

 

3.9. Waveform Output Settings 
 
3.9.1. Waveform Output Start Position/End Position 
 
Set the waveform output start position/end position. 
 

Toolbar Shortcut key 

 Shift + F1 

 
Table 26 

Start position 

 

Sets waveform output start position. 
When the waveform unit button is displayed as PTN(s), the waveform unit is 
set to PTN(s). 
When the waveform unit button is displayed as Time, the waveform unit is set 
to time. 
The possible setting range is 0 to 12,287 in PTN(s). 
In time unit, the start position can be set in the rage of ０ to 12,287 x data 
rate (time per 1PTN(s)). 
You can increase and decrease a numeric value with the spin button or 
directly enter a numeric value. 

Start unit 

 or  

Sets the unit for waveform output start. 
When the waveform unit button is displayed as PTN(s), the waveform unit is 
fixed to PTN(s). 
When the waveform unit button is displayed as Time, the waveform unit is set 
to time. 
Every time you press the unit display section, the unit indication changes in 
the sequence of ns (nanosecond) → us (microsecond) → ms (millisecond) → 
sec (second). 

End position 

 

Sets waveform output end position. 
The unit and range are same as those for waveform output start position. 

End Unit 

 or  

Sets the unit for waveform output end. 
The indication and unit switching sequence are same as those for unit for 
waveform output start. 

 
 

 

Every time you press the corresponding shortcut key, the focus moves in the sequence of 
"Start position" → "Start unit*1 " → "End position" → "End unit.*1 " The setting of the focused 
position can be changed using UP/DOWN arrow keys (↑/↓). 
 
*1: It will not focus when Waveform Unit is 'PTN'. 
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3.9.2. Data Rate 
 
Set the data rate at which waveforms are output. Set the data rate in bps or time per 1PTN (s). 
 

Toolbar Shortcut key 

 Shift + F2 

 
Table 27 

Data rate 

 

Sets the data rate at which waveforms are output. 
For the possible setting range, refer to Table 28 below. 
It is not possible to output Hi-Z data at a data rate at which Hi-Z data cannot 
be output, but as long as Hi-Z data does not exist in the output range, 
you can output data without changing the data rate or deleting Hi-Z 
data. 
At a data rate at which Hi-Z data cannot be output, if a waveform data in the 
output range contains Hi-Z data, a message dialog (Table 22) is displayed and 
output is disabled. 

Data rate unit 

 or  

Set the unit of data rate. 
Every time you click here, the indication switches between sec (time per 
1PTN) and bps. 

 
Table 28 

 

Data rate (bps) Data rate (sec) Hi-Z output 

100 10m Allowed 
200 5m Allowed 
250 4.0m Allowed 
400 2.5m Allowed 
500 2.0m Allowed 
1.0K 1.0m Allowed 
2.0K 500u Allowed 
2.5K 400u Allowed 
4.0K 250u Allowed 
5.0K 200u Allowed 
10K 100u Allowed 
20K 50u Allowed 
25K 40u Allowed 
40K 25u Allowed 

 

Data rate (bps) Data rate (sec) Hi-Z output 

50K 20u Allowed 
100K 10u Allowed 
200K 5.0u Allowed 
250K 4.0u Allowed 
400K 2.5u Allowed 
500K 2.0u Allowed 
1.0M 1.0u Allowed 
2.0M 500n Not allowed 
2.5M 400n Not allowed 
4.0M 250n Not allowed 
5.0M 200n Not allowed 
10M 100n Not allowed 
20M 50n Not allowed 

   
 

 

 

Every time you press the corresponding short cut key, the focus moves to "Data Rate" → 
"Data Rate Unit" in this order. 
The setting of the focused position can be changed using UP/DOWN arrow keys (↑/↓). 
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3.9.3. Output Voltage 
 
Set the voltage at which waveforms are output. 
 

Toolbar Shortcut key 

 Shift + F3 

 
Table 29 

Output 
Select the voltage at which waveforms are output from 1.2, 1.5, 1.8, 2.5, and 
3.3 (V). 

 
 
3.9.4. Operation Mode 
 
Set the operation mode (Repeat mode or Keep mode) in which waveforms are output. 
The Repeat mode and Keep mode are set exclusively. They cannot be set at the same time. 
 

Toolbar Shortcut key 

 Shift + F6 

 
Table 30 

Repeat 

 

Checking this checkbox enables the Repeat mode. 
This checkbox cannot be selected when the Keep mode is enabled. 
When Repeat mode is disabled: 
If you press the Waveform output start button, the waveform between Start 
and End is output once. 
When an external trigger is specified, the waveform is output once when a 
trigger occurs. 
When Repeat mode is enabled: 
If you press the Waveform output start button, the waveforms between 
Start and End are output repeatedly. 
When an external trigger is specified, the waveforms are output repeatedly 
after a trigger occurs. 

Keep 

 

Checking this checkbox enables the Keep mode. 
This checkbox cannot be selected when the Repeat mode is enabled. 
When Keep mode is disabled: 
After the final data is output, the output from the probe becomes Hi-Z data. 
When Keep mode is enabled: 
After the final data is output, the output is retained. 

 

 

Every time you press the corresponding shortcut key, the focus moves to "Repeat" → "Keep" 
in this order. 
When the focus is on either of the above buttons, pressing the Space key changes the selection 
status. 
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3.9.5. Waveform Output Start Trigger 
 
Set the trigger condition for waveform output start. 
The button indicates the current setting status. 
Every time you press this button, the indication changes to "No EXT" → "EXT↑" → "EXT↓" in this order. 
 

Toolbar Shortcut key 

   Shift + F7 

 
 

Table 31 

No EXT 
External trigger is disabled. Output of waveform can be started only via the 
Waveform output start button. 

EXT↑ Rise of external trigger signal starts output of waveform. 

EXT↓ Fall of external trigger signal starts output of waveform. 
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3.10. Waveform Unit Setting 
 
Set the minimum unit of waveform. 
The button indicates the current setting status. 
Pressing this button switches the indication between "PTN" and "Time." 
 

Toolbar Shortcut key 

  Shift + F8 

 
 

Table 32 

PTN Sets the unit for waveform output start/end positions and the cursor to PTN. 

Time 
Sets the unit for waveform output start/end positions and the cursor to time 
(ns/us/ms/sec). 
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3.11. Waveform Edit Mode Setting 
 
Set the waveform edit mode. 
The indication on the button represents the mode to be switched to after pressing this button. 
Pressing this button switches the mode between "Compact" and "Edit." 
 

Toolbar Shortcut key 

  Shift + F9 

 
Table 33 

Compact 
If you press this button while it is displayed this way, the mode is switched to the 
Compact mode. 

Edit 
If you press this button while it is displayed this way, the mode is switched to the 
Edit mode. 

 
 

 For details of each mode, refer to "4.1. Main Window." 
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4. Windows 

4.1. Main Window 
 
The main window can be displayed in two modes: Edit mode and Compact mode. 
The mode can be switched by using the following buttons. 
 

Toolbar Shortcut key 

  Shift + F8 

 
 
4.1.1. Edit Mode 
 
This is the mode in which waveforms are edited. You can use all the functions. 
 

 
Figure 28 

 
4.1.2. Compact Mode 
 
This is a mode dedicated to waveform output operations. The menu and tool bar related to edition are 
not displayed. 
 

 
Figure 29 
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4.2. Waveform area 
 
The waveform areas can be roughly classified as follows. 
Each green line represents the border between areas, and by dragging the green line, you can change 
the size of the corresponding area. 
 
 
 
 

 
 
 

Figure 30 
 
 
A single line represents a single signal, and the selected signal is indicated with a light-blue background. 
Figure 31 shows an example in which Signal 1 is selected. 
 

 
Figure 31 

 
 

(2) Edition area 

(1) Signal name and 
cursor value display 

area 

(4) Waveform display position 

(3) Cursor operation 
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4.2.1. Signal Name/Cursor Value Display Area 
 
The signal name/cursor value display area displays signal names and values of signals at the position 
indicated by the cursor. 
 

 
Figure 32 

 

1 2 3 
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Table 34 

(1) Channel No. 

Displays channel numbers. 
By dragging and dropping the channel number indication, you can switch the order 
of signals. 
Clicking a signal number puts it into a selected state. 

(2) Signal name 

Displays signal names. 
Clicking a character string puts the signal name into an editable state, allowing you 
to change the signal name. 
When a signal is a bus or a bus element, right-clicking it displays the context menu. 
(For context menu, refer to Figure 37.) 
Double-clicking a signal name for single signal turns it to a bus. 

(3) Cursor value 

Displays the values of signals at the position selected by the cursor. 
During step-by-step output, this section displays the signal values at the position 
where the step-by-step output is performed. In this case, the numeric values are 
displayed in green. 
When a bus is displayed, its numeric value is appended with "h" at its end if the 
value is a hexadecimal number and appended with "b" if the value is a binary 
number. For a decimal value, the numeric value only is displayed. 
The display unit of bus can be changed from the context menu for signal name. 
When the number of digits is too large to fit in the display area, "#" is displayed. 

 
 

 
To extend the cursor value display area (3), extend "(1) Signal name and cursor value display 
area" in Figure 30. 

 
 
● Change method of signal name display size 
 
By dragging the splitter (Figure 33) at the label position in the signal name/cursor value display area to 
right and left, you can change the size of the signal name display area. 
 
 
 
 

 
 

Figure 33 
 

Splitter 
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● Bus creation method 
 
Bus can be created by operating the mouse. 
Figure 34 shows its procedures. 
The signal name of a signal (= child element) added to the bus will be changed to "signal name of parent 
element + {bit position}." Even if you change the bit position, the signal name will be automatically 
changed. 
However, it is not replaced when the signal name is changed even if a bit position is changed. 
 

 
 
 
 
 
 

Figure 34 
 
● Method for canceling bus state 
 
Bus state can be canceled by operating the mouse. 
Figure 35 shows its procedures. 
By dragging and dropping a signal (= child element) that has been added to the bus to a position other 
than the bus, you can return it to a single signal. 
 

 
 
 
 

Figure 35 
 

(1) Double-click the 
signal name to 
turn it into the bus 
parent element. 

(2) Drag and drop 
the channel number 
which you want to 
turn into a bus child 
element. 

(3) To change the bit 
position of the child 
element, drag and drop the 
channel number of the child 
element you want to move. 

(4) The bit position 
changes. 

(1) Drag and drop the channel number of 
the signal that you want to remove from 
the bus to a position other than the bus. 

(2) The signal returns 
to a single signal. 



 

63 / 74 
Universal Probe Software Users Manual – Pattern Generator 

 

 
You can also cancel the bus state from the context menu that is displayed by right-clicking the 
channel number. 

 
● Switching of bus expansion/folding 
 
By using  and  buttons displayed in the bus signal name section, you can switch between the 
expanded state and folded state of bus child element. 
 

 
Figure 36 

 
Table 35 

 Expands (displayed state) the bus child element. 

 Folds (hidden state) the bus child element. 
 
 
● Context menu 
 
When a signal is a bus or a bus element, right-clicking the corresponding signal name portion displays 
the context menu. 
 

 
Figure 37 

 
Table 36 

Bus Display Format Changes the bus display format. This setting can be specified for parent 
element only. 
Hex : Displays the bus value in hexadecimal notation. 
Decimal : Displays the bus value in decimal notation. 
Binary : Displays the bus value in binary notation. 
ASCII : Displays the bus value in ASCII notation. 

Cancel Bus Removes the selected bus child element from the bus. This function can be 
selected for bus child elements only. 

 

 
The bus display format will be reflected to the cursor value and the signal display in the 
waveform area. 
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4.2.2. Edition Area 
 
In the edition area, display and edit waveforms. 
 

  

 
 

Figure 38 
 
 

Table 37 

(1) Scale display Scale for waveform display position/time. 

(2) Waveform display area Display area of waveform. 

(3) Grid 

In the edition area, dotted lines are displayed at specified grid intervals. 
 

 For setting of grid, refer to "3.5.13. Grid Interval." 
 

(4) Outside of output 
range 

The area to the left of the waveform output start and the area to the right 
of the waveform output end are grayed out as areas outside the output 
range. 

(5) Output start/end 
positions 

The red lines represent cursors indicating the waveform output start/end 
positions. 
 

 
For setting of waveform output start/end positions using cursor, 
refer to "4.2.3. Cursor." 

 

(6) Cursor The blue line represents the cursor. 

(7) Step-by-step output 
position 

While step-by-step output is being performed, the output position is 
indicated by a green dashed line. 

(8) Range selection 
By dragging the mouse on the waveform display area, you can select a 
desired area. 
The details of the selection are described later in this section. 

1 

2 

3 

4 4 

5 5 

6 6 6 7 

8 
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● Movement of display position 
 
By dragging the edition area while holding down the Shift key, you can move the display position in the 
dragging direction. 
 
 
● Signal display in waveform display area 
 
In the waveform display area, signals are displayed as shown in Table 38. 
 
 

(1) Display of single signal                  (2) Display of bus 

 
Figure 39 

 
 

Table 38 

(1) Single signal display 

The upper line indicates that the value is 1 (= High Level). 
The lower line indicates that the value is 0 (= Low Level). 
The middle line indicates that the value is Hi-Z. 
In a reduced display, when a single dot contains multiple data, the dot is 
displayed in the following color. 

The rate of value 1 is 50% or below:                (light gray) 
The rate of value 1 is 50% or above:                (dark gray) 

(2) Bus display 
For the bus, values are displayed in hexagons. 
If the bus child element signals contain any Hi-Z value, the bus value in 
each hexagon is indicated with “X.” 
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● Range selection in edition area 
 
During edition of waveform, you can select the range to edit by using the mouse. 
Depending on the selection status of "Align to Grid" and "Align to Edge," the selection result is made 
differently. 
Regardless of "Align to Grid" and "Align to Edge" settings, the selection range in the vertical direction is 
corrected in units of signal (units of line). 
 

Table 39 

Align to Grid = disabled 
Align to Edge = disabled 

The range dragged by the mouse is selected as is. 

Align to Grid = enabled 
Align to Edge = disabled 

Corrects the selection range to the position of the nearest grid as shown 
below. 

 
 

Align to Grid = disabled 
Align to Edge = enabled 

Corrects the selection range to the position of the nearest edge of another 
signal as shown below. 

 

Align to Grid = enabled 
Align to Edge = enabled 

Corrects the selection range to the position of grid or edge, whichever 
nearer. 

 
 

 
For setting of Align to Grid, refer to "3.5.11. Align to Grid" and for setting of Align to Edge, 
refer to "3.5.12. Align to Edge." 
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4.2.3. Cursor Operation 
 
The cursor operations include movement of cursor, addition and deletion of cursor, and others. 
 
 
 

 
 
 
 

Figure 40 
 

Table 40 

(1) Cursor number 

Displays cursor numbers. The numbers are automatically set. 
The cursor of the clicked line turns into a selected state. 
The background color of a line changes to light blue when it is selected. 
Also, the color of the cursor tag is inverted. 

(2) Cursor 
addition/deletion 

 /  

Clicking the "+" button adds a cursor to below the selected line. To the 
added cursor, the subsequent number is automatically assigned. The 
cursor numbers below the added line increases by 1. 
Clicking the "-" button deletes the selected cursor. The cursor numbers 
below the deleted line decreases by 1. The maximum number of cursors is 
20. 

(3) Cursor position 
Displays the position of the cursor. 
If you click the cursor position, you will be able to enter a numeric value. 

(4) Waveform output 
start/end positions 

These marks indicate the start position (S mark) and the end position (E 
mark) of waveform output. 
Dragging the rectangle portion changes the start/end position. 
 

 
For setting of waveform output start/end positions using tool 
bar, refer to "3.9.1. Waveform Output Start Position/End ." 

 

(5) Cursor 
Clicking the rectangle portion turns the clicked cursor into a selected state. 
By dragging the cursor, its position can be changed. 

(6) Cursor-to-cursor 
distance display 

Displays the distance from the next cursor. 

 

 

The cursor position can be moved by using the menu bar or tool bar. Refer to "3.4.7. Cursor → 
Move to Right Edge," "3.4.6. Cursor → Move to Left Edge," "3.4.7. Cursor → Move to Right 
Edge 
 
Moves the selected cursor to the next right change point of the selected signal. 
If no signal is selected, the selected cursor is moved to the next right change point of a signal 

1 2 3 

4 4 

5 
5 

6 
6 
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that comes first. 
 
Figure 15 and Figure 16 are examples showing how the cursor is moved. 
 

Tool button Operation on the menu bar Shortcut key 

 Display Waveform → Cursor → Move to Right Edge --- 

 
 

 For a bus, the cursor is moved to the point where a value change occurs. 

 
 
 
3.4.8. Move to Edge," "3.4.9. Start Waveform Output ← Cursor Position," and "3.4.10. End 
Waveform Output ← Cursor Position." 
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4.2.4. Waveform Display Position 
 
The waveform display position displays the position of the waveform area in the whole waveform, 
change of waveform area position, cursor position in the whole waveform, and other information. 
 
 
 

 
 
 
 

Figure 41 
 
 

Table 41 

(1) Waveform display 
position 

Indicates the range displayed in the waveform area and its rate to the 
whole wave form as a gray bar. 
By dragging the bar, you can move the waveform display position. 

(2) Cursor position The blue line represents the cursor position in the whole waveform. 

(3) Waveform output 
start/end positions 

The red lines represent the waveform output start/end positions. 

(4) Background 
The black background represents the whole waveform. 
If you click a position other than the bar, the display position is moved to 
the position centering around the clicked position. 

 
 
 

1 

2 2 2 

3 3 
4 
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4.3. Status Bar 
 
The status bar displays the operation status. 
 
 
 

 
Figure 42 

 
 
 

Table 42 

(1) Operation status 
display 

Displays the operation status of the probe. 
Outputting Waveform : Indicates that the probe is outputting waveform. 
Stopped : Indicates the state in which waveform is not output. 
Disconnected : Indicates the state in which the probe is disconnected. 

(2) Cursor position 
display 

Displays the position of the cursor that is currently selected. 

 
 
 

1 2 
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5. License Registration 
 
To use this product, its license needs to be registered. 
If you select a probe whose license has not been registered yet and press the "Register License" button 
in the Select Unit dialog box shown in "3.7.1. Connection," the following dialog box is displayed. 
 

 
Figure 43 

 
 

Table 43 

Serial number 
Displays the serial number of the probe whose license you are going to 
register. 

License Code Enter the License Code. 
 
If the License Code contains any error, an error message is displayed. Check if License Code is correctly 
entered. 
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A. Appendix 

A.1. HW Connection Errors 
 
These are errors that occur at the time of connection, start of waveform output, and step-by-step output. 
 

Message Description 

Internal Error Internal error of this software. 

Incorrect argument Internal error of this software. 

Interface is not initialized. Internal error of this software. 

Communication error Failed to communicate with probe. 

Invalid device ID Internal error of this software. 

Device is not initialized. Internal error of this software. 

Function is different. Already initialized by another function. 

Device is running. Internal error of this software. 

Canceled. Internal error of this software. 

No license. License is unregistered or invalid. Register the license again. 

Memory shortage Memory is running short. Check the memory consumption status 
with Task Manager or the like, exit unnecessary software, and 
restart this software. 

Number of connected units does 
not match. 

After connection, probe(s) may have been removed before starting 
output. Check the probe connection. 
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Revision History 
 

Ver. No. Revision date Content of revision 

01 09/30/2014 Initial Release. 

02 11/17/2014 Correction of typographical errors. 
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Manufacturer Information 
 

 
 

Sohwa & Sophia Technologies Inc. 
 
 

 

[Headquarters] 

Postal code: 215-8588 
6-2, Minami-kurokawa, Asao-ku, Kawasaki City, Kanagawa Pref., 
215-8588, JAPAN 
Web : http://www.ss-technologies.co.jp/en/index.html 

 
 
 
 

Subsidiary 
 

 

SOHWA MALAYSIA SND. BHD. 
 

Unit 5-2, Level 5, Tower 6, Avenue 5, 
The Horizon, Bangsar South No.8, Jalan Kerinchi 
59200, Kuala Lumpur, Malaysia 
 
HomePage : http://www.sohwa-m.com.my/ 
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