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NOTES 
 
Thank you for purchasing the “Universal Probe” from Sohwa & Sophia Technologies. Correctly 
understand notes and other information in this document before using this product. 
 
 
1. A permission from the Japanese government is required when exporting the product and 

technologies described in this document to which the “Foreign Exchange and Foreign Trade Act” 
applies or bringing them out of Japan. 

2. The product described in this document is intended to be used in general electronics such as 
business equipment, communication equipment, measurement equipment, or home appliances. Do 
not use this product in special-purpose equipment such as automobile, railway, marine, or 
aerospace equipment, transportation equipment, combustion equipment, safety devices, medical 
equipment, infrastructure equipment, or nuclear power that requires special quality and reliability 
and of which failure or malfunction may directly threaten human lives or injure human bodies. The 
customer should be responsible for using this product in such equipment. 

3. It is strictly prohibited to reprint this document in whole or in part without our written permission. 
4. The contents of this document are subject to changes without notice. 
5. The specifications in this document may lead to different results depending on your environment or 

measurement conditions. 
6. Note that we bear no responsibility for consequence of operating this product. 
7. “Operating Precautions” in this document are important notes to prevent damage on users and 

third parties as well as assets and to use the product safely and correctly. Be sure to read these 
precautions before using this product. 

8. The product names and trade names in this document are trademarks or registered trademarks of 
respective owners. 

 
 
 
 
 

 
Contact information can be obtained on the website of Sohwa & Sophia Technologies Inc. 
URL > http://www.ss-technologies.co.jp/en/index.html 

 
 
 
 
 
 

http://www.ss-technologies.co.jp/
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Operating Precautions 
 

 

Failure to observe the following precautions may lead to human death or 
severe injury. 

  

 
Do 

Avoid supplying voltage out of the range specified in the specifications of this product. 
Supplying the voltage out of the range may cause damage or fire. 

 
Do 

When using the target equipped with the ground terminal, ensure that the ground 
terminals of the target and peripheral equipment are connected. Failure to do so may 
cause an equipment failure or electric shock. 
Avoid connecting the ground terminal to the gas pipe. This causes a fire or explosion. 

 
Don't 

Do not transport this product with equipment connected. 
In particular, hold the plug when removing or inserting the cable. Failure to do so may 
damage the cable, causing a fire or electric shock. 

 
Don't 

Observe the following points when handling the cable. Do not damage, process, 
forcibly bend, twist, pull, putting any object on or heat the cable, moving the cable 
close to the heating device, or touch the cable with a wet hand. 
Failure to observe these precautions may cause a fire or electric shock. 
If the cable is damaged, stop using it. 

 
Don't 

When you hear thunders, do not touch the power plug. This causes an electric shock. 
If the product seems to be damaged by lightning strike, stop using it. 

 
Don't 

Do not let a staple, clip or other metal item enter into the product. This may cause a fire 
or failure. 

 
Don't 

Do not use or leave the product in direct sunlight, near heating devices, in an extremely 
hot or cold environment, under hard vibrations, in dusty area with a large amount of 
metal dust or oily dust, or noisy area full of spike noise. 
Do not apply a strong shock to the product. 

 
Do not 

disassemble 

Do not disassemble, alter or repair the product. This may cause a fire or electric shock. 

 
No wetting 

Do not use the product at a place where there is liquid or at a humid place such as 
bathroom or in vicinity to glasses. 
This may cause an electric shock. 
If liquid enters into this product, immediately turn it off and stop using it. 

 
Caution 

Touching the energized product for a long time may cause low-temperature burns. 
Do not use this product covering with comforter or other cloth. 

 
Pull out the 

plug. 

Immediately turn the power off if unusual smell, noise, smoke or fire is detected or if 
the product is or may be damaged due to a fall or strong shock. Continuing to use it 
may lead to a serious accident. Stop using the product. 
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Abbreviations, Terms and Conventions 
This section describes the abbreviations, terms and conventions used in this document. 
 

 About numeric values ... All the numeric values are positive unless otherwise specified. 
 K (capital letter) ... Represents 210=1024. (Example: 16K=16384) 
 k (small letter) ... Represents 1000. (Example: 1kHz=1000Hz) 
 [xxxxx] ... Represents the window title, xxxxx. 
 <xxxxx> ... Represents the item named xxxxx in the window. 

 
 
 
The annotations and notes used in this document are as shown in Figure 1. 
 
 
 

 Information reference. 

 
 

 Supplementary information. 

 
 

 Caution. Be sure to read this. 

 
 

Figure 1 
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The abbreviations and terms are as shown in Table 1. 
 

Table 1 
Abbreviations and 
terms 

Description 

This product Universal Probe including accessories. 

Probe Universal Probe itself. 

This software Firmware Selector. 

Firmware Control application that operates on the Universal Probe. 

IDE Integrated development environment. 

CMSIS-DAP 
Standards for connecting the integrated development environment and the 
probe. 

S/N Stands for the serial number. Probe ID. 

FW Stands for the firmware. 

Ver Stands for the version. Version number of firmware. 

ARM Writer JTAG memory writer for ARM. (Option software) 

SPI Writer Memory writer for SPI connection. (Option software) 

LA Stands for Logic Analyzer. (Option software) 

PG Stands for Pattern Generator. (Option software) 

License Code 
Code to add the functions that can be used in this device. This code is required 
for each function. 

Host PC PC where this software runs. 

N/A 
Stands for not available. This abbreviation indicates that the item cannot be 
used. 
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1. Overview of This Software 
This chapter provides an overview of this software. 
This software is used to change or update the firmware for the Universal Probe. 
The following two types of firmware are provided for the Universal Probe. 
 

Table 2 

Firmware Description 

Standard 
configuration 

Firmware installed when the Universal Probe is shipped. 

CMSIS-DAP 
configuration 

Firmware used to connect to the IDE. The CMSIS-DAP standards are used for 
this connection. 

 
This software can be used to change respective firmware or update the version of CMSIS-DAP firmware 
for the probe connected to the host PC. 
 

1.1. System Requirements 
 
The following system is required to run this software. 
 

 PC running Microsoft Windows 7 or later 
 CPU: 1GHz or faster (depending on the requirements of the used OS) 
 Memory: 1GB or larger (depending on the requirements of the used OS) 
 HDD: 500MB or larger free hard disk space 
 OS : Windows 7 or later (32bit or 64bit versions are supported) 
 One or more empty USB 2.0 ports 
 .NET Framework 4.5 or higher. 

 

1.2. Characteristics 
 
This software has the following characteristics. 
 

 Lists the serial numbers, firmware types, and versions of the probes connected to the host PC. 
 Displays the registration status of license code for the selected probe. 
 Changes the firmware for the selected probe. 
 Updates the CMSIS-DAP firmware for the selected probe. 
 Manages the downloaded CMSIS-DAP firmware. 
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1.3. Turning On or Off the Power 
 
1.3.1. Turning On the Power 
 
Turning on the power with the following procedure: 
 

1) Connect the USB cable of the probe. 
2) Start this software, and do such as the changing of firmware. 

 
 
1.3.2. Turning Off the Power 
 
Turning off the power with the following procedure: 
 

1) Exit this software. 
2) Disconnect the USB cable of the probe. 

 

 For details of the hardware specifications of probe, refer to the “Hardware Users Manual.” 
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2. How to Operate 
This chapter explains how to operate this software. 
 

2.1. Starting This Software 
 
This section describes how to start this software. 
 
 
2.1.1. Starting Operations 
 
Click "All Programs" → "Universal Probe" → "Firmware Selector" from the "Start" menu. 

 

 
Figure 2 
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These operations start this software as shown in the figure below. 
 

 
Figure 3 

 
When this software starts, the probes connected to the host PC are displayed. 
 

2.2. Exiting This Software 
 
This section describes how to exit this software. 
 
 
2.2.1. When Using the Application Menu 
 
Select the following menu items to exit this software. 
 
Tool button Operation on the menu bar Shortcut key 

--- File → Exit Alt + F4 

 
 
2.2.2. When Using the Button 
 
Click the X button at the right top of the window. 
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2.2.3. When Using the System Menu 
 
Double-click the icon at the left top of the window. Or, click at the left top of the window, right-click the 
caption, or press the Alt + Space keys to display the system menu and select “Close.” 
 

2.3. Changing or Updating Firmware 
 
This section describes how to change and update firmware in this software. 
 
 
2.3.1. Main Window 
 
The main window of this software is shown below. 
 

 
Figure 4 

 
The serial numbers, firmware types, and versions of the Universal Probes connected to the host PC are 
displayed when the software starts. 
 
 
2.3.2. Writing CMSIS-DAP Firmware 
 
To change the standard firmware to the CMSIS-DAP firmware, select the Universal Probe for which 
firmware is changed and click the following menu bar items.  
 
Tool button Operation on the menu bar Shortcut key 

--- Tools → Write CMSIS-DAP Firmware --- 
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Or, click the following context menu item. 
 
 
Tool button Operation on the context menu Shortcut key 

--- Write CMSIS-DAP Firmware --- 

 
The [Select CMSIS-DAP Firmware] window opens. 
 

 
Figure 5 

 
Select the CMSIS-DAP firmware to be written into the Universal Probe from the <CMSIS-DAP firmwares> 
list and click     button. The confirmation message is displayed. 
 

 

Figure 6 
 
Clicking     button displays the [Writing Firmware] window and writes the selected CMSIS-DAP 
firmware into the Universal Probe. 
 
 

 

The license code must be registered to change the standard firmware to the CMSIS-DAP 
firmware. If the license code is not registered in the probe, register it by referring to 
"Registering the license code." 

 

Yes 

Write 
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The progress is displayed while firmware is being written. 
 

 
Figure 7 

 

 Do not turn off the PC or remove the Universal Probe while firmware is being written. 

 
 
The probe list is updated when the firmware is completely written. 
 
 

 

If the probe for which the new firmware was written is not displayed in the list after the 
firmware is completely written, remove the probe from the host PC, connect it again, and then 
update the list. 
Please refer to "2.6. Updating Probe Information." for details.  

 
 
● Registering the license code 
 
If the license code for the charge-free software is not registered in the probe, the [License Registration] 
window is displayed when the CMSIS-DAP firmware is written. 
 

 
Figure 8 

 
 
Enter the license code in <License Code>. When the license code is registered, the CMSIS-DAP firmware 
is written. 
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● Notes on entering the license code 
 
Enter exactly the same license code as the received information. 
 
 

 
If the license code is rejected even though it matches the code in the received email, contact 
us. 

 
 
● Error display list 
 

Table 3 

Display Meaning Action 

Invalid license code. Displayed when the license code 
cannot be analyzed due to invalid 
format of license code or for 
other reasons. 

Check the email that includes the 
license and enter it again. 

The license code does not 
match the serial number. 

Displayed when the S/N of the 
selected probe does not match 
the S/N of the probe to which the 
license code applies. 

Check the email that includes the 
license code and enter it again. 

The license code is not for 
CMSIS-DAP. 

Displayed when the license code 
does not apply to charge-free 
software. 

Check the email that includes the 
license code and enter it again. 

License information cannot be 
obtained from the probe. 
The probe may not be working. 

Displayed when information 
required for license 
authentication cannot be 
obtained from the probe. 

Reconnect the probe and the host 
PC (by removing and reinserting it 
from and to the USB port) and 
restart this software. 
Contact us if this message 
continues to appear. 

 
 

 
It is also possible to check whether the license code is registered or not. 
Please refer to "2.5. Viewing the Registration Status of License Code." for detail.  

 
 
2.3.3. Updating CMSIS-DAP Firmware 
 
To change the CMSIS-DAP firmware written in the Universal Probe to another version of CMSIS-DAP 
firmware, use the same operation as the one described in “2.3.2. Writing CMSIS-DAP Firmware.” 
 
 

 Refer to "2.3.2. Writing CMSIS-DAP Firmware." 

 
 

 
The CMSIS-DAP firmware used for update must be registered in this software. 
Please refer to "2.4.1. Adding CMSIS-DAP Firmware." for details.  
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2.3.4. Writing Standard Firmware 
 
To change the CMSIS-DAP firmware to the standard firmware, select the Universal Probe for which 
firmware is changed and click the following menu bar items.  
 
Tool button Operation on the menu bar Shortcut key 

--- Tools → Write Standard Firmware --- 

 
Or, click the following context menu item. 
 
Tool button Operation on the context menu Shortcut key 

--- Write Standard Firmware --- 

 
The [Select Standard Firmware] window opens. 
 

 
Figure 9 

 
Select the software where the standard firmware to be written into the Universal Probe is located from 
the <Installed Softwares> list and click     button. The confirmation message is displayed. 
 

 

Figure 10 

Write 
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Clicking     button displays the [Writing Firmware] window and writes the standard firmware 
located in the selected installed software into the Universal Probe. 
 
The progress is displayed while firmware is being written. 
 
 

 
Figure 11 

 

 Do not turn off the PC or remove the Universal Probe while firmware is being written. 

 
 
The probe list is updated when the firmware is completely written. 
 
 

 

If the probe for which the new firmware was written is not displayed in the list after the 
firmware is completely written, remove the probe from the host PC, connect it again, and then 
update the list. 
Please refer to "2.6. Updating Probe Information." for details. 

 
 

 

Because the standard firmware depends on the version of respective software for the Universal 
Probe, the version optimal to respective software is installed with the software. 
If a different version of standard firmware is written when the software starts, the firmware 
installed with the started software will be written. 

 
Usually, the rewriting of the firmware is necessary, it is only when you are using the CMSIS-DAP function. 
If you want to use in other than the CMSIS-DAP, it rewrites automatically to the standard firmware at the 
time of each software start-up. 

Yes 
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2.4. Managing CMSIS-DAP Firmware 
 
This section describes how to manage the CMSIS-DAP firmware used to change or update this software. 
If the version of CMSIS-DAP firmware is upgraded, the new CMSIS-DAP firmware can be downloaded 
from our Web site. 
 
 
2.4.1. Adding CMSIS-DAP Firmware 
 
Click the following toolbar button or menu bar items. 
 
Tool button Operation on the menu bar Shortcut key 

 Tools → Manage CMSIS-DAP Firmware --- 

 
The [Manage CMSIS-DAP Firmware] window opens. 
 

 
Figure 12 

 
Clicking     button opens the [Open] window. 
 

Add 
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Figure 13 

 
Select the downloaded CMSIS-DAP firmware file and click     button to add it to the <CMSIS-DAP 
firmwares> list. 
 
If the same version of CMSIS-DAP firmware is already registered, the confirmation message is displayed. 
 

 

Figure 14 
 
Clicking     button overwrites the CMSIS-DAP firmware. 
 
 
 
 
 
 
 
 
 
 
 
 

Open 

Yes 
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2.3.2. Deleting Registered CMSIS-DAP Firmware 
 
Click the following toolbar button or menu bar items. 
 
Tool button Operation on the menu bar Shortcut key 

 Tools → Manage CMSIS-DAP Firmware --- 

 
The [Manage CMSIS-DAP Firmware] window opens. 
 

 
Figure 15 

 
When you select the CMSIS-DAP firmware to be deleted and click     button, the following 
confirmation message is displayed. 
 

 

Figure 16 
 
Clicking     button deletes the CMSIS-DAP firmware. 

Delete 

Yes 
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2.5. Viewing the Registration Status of License Code 
 
This section describes how to check the registration status of the license code registered in the probe in 
this software. 
 

 
Only the license code for the charge-free software can be registered in this software.  
Register other license codes in respective software. 

 
 
2.5.1. Checking the Registration Status of the License Code for the Selected Probe 
 
Select the probe for which registration status of license code you want to check in the main window. 
 

 
Figure 17 

 
Select the probe and click the following toolbar button or menu bar items. 
 
Tool button Operation on the menu bar Shortcut key 

 File → Properties --- 

 
Or, click the following context menu item. 
 
Tool button Operation on the context menu Shortcut key 

 Properties --- 
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The [Properties] window shown below opens. 
 

 
Figure 18 

 
The properties for the selected probe is displayed in the <Properties> list. The items displayed in the 
<Property> and <Value> fields have the following meanings. 
 

Table 4 

Property Description 

S/N Serial number of probe. 
FW Type of firmware currently written. “CMSIS-DAP” or “standard.” 
Ver Version of firmware currently written. 
Charge-Free CMSIS-DAP firmware, Boundary-Scan Tool, Registration statuses of license codes for 

ARM Writer[Size-limited] and SPI Writer[Size-limited]. 
ARM Writer Registration status of license code for ARM Writer. 
SPI Writer Registration status of license code for SPI Writer. 
LA Registration status of license code for Logic Analyzer. 
PG Registration status of license code for Pattern Generator. 
 
 

Table 5 

Value Description 

Available The license code is registered. The software can be used. 
N/A The license code is not registered. The software cannot be used. 
- Data cannot be acquired due to an error or other cause. 
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2.5.2. Listing the Registration Status of the License Code for the Probe 
 
Change the main window to the detailed view to list the registration statuses of license codes for all the 
probes currently connected to the host PC. 
Click the following toolbar button or menu bar items to switch to the list view. 
 
Tool button Operation on the menu bar Shortcut key 

 View → Details --- 

 
The registration statuses of license codes for each probe are displayed in the table format as shown 
below. 
 

 
Figure 19 

 
Each item in the table is described below. 
 

Table 6 

Item Description 

S/N Serial number of probe. 
FW Type of firmware currently written. “CMSIS-DAP” or “standard.” 
Ver Version of firmware currently written. 
Charge-Free CMSIS-DAP firmware, Boundary-Scan Tool, Registration statuses of license codes for 

ARM Writer[Size-limited] and SPI Writer[Size-limited]. 
ARM Writer Registration status of license code for ARM Writer. 
SPI Writer Registration status of license code for SPI Writer. 
LA Registration status of license code for Logic Analyzer. 
PG Registration status of license code for Pattern Generator. 
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Click the following toolbar button or menu bar items to switch to the icon view. 
 
Tool button Operation on the menu bar Shortcut key 

 View → Icon --- 

 
 

 
Figure 20 
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2.6. Updating Probe Information 
 
This section describes how to update the probe display in this software. 
 
Click the following menu bar items to update probe information. 
 
Tool button Operation on the menu bar Shortcut key 

--- View → Refresh F5 

 

2.7. Help 
 
This section describes how to display the help and version information on this software. 
 
 
2.7.1. Displaying Help 
 
Click the following menu bar items to display the help. 
 
Tool button Operation on the menu bar Shortcut key 

--- Help → View Help --- 

 
The page for Universal Probe in our web site is shown. Please download the manual and read it.. 
 
 
2.7.2. Displaying Version Information 
 
Click the following menu bar items to display the version information on this software. 
 
Tool button Operation on the menu bar Shortcut key 

--- Help → About --- 
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The <Version Information> window is displayed. 
 

 

Figure 21 
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Revision History 
 

Ver. No. Revision date Content of revision 

01 09/29/2014 Initial Release. 

02 10/07/2014 Added “1.3. Turning On or Off the Power”. 

03 11/17/2014 Correction of typographical errors. 
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[Headquarters] 
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215-8588, JAPAN 
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Subsidiary 
 

 

SOHWA MALAYSIA SND. BHD. 
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The Horizon, Bangsar South No.8, Jalan Kerinchi 
59200, Kuala Lumpur, Malaysia 
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